Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Příspěvky - Hynek (Pichi) Vychodil

Stran: [1] 2 3 4
1
Všeobecná podpora / Re:Poškození souborů na ext4
« kdy: 08. 12. 2011, 17:44:27 »
Otevři si nějaký terminál a pak napiš rm P a pak zmáčkni <Tab>. Mělo by se ti tam objevit něco co odpovídá tomu souboru.

2
Správa a instalace softwaru / Re:xfce4.6 - pomalé spuštění
« kdy: 07. 11. 2011, 16:39:59 »
Koukni se jestli máš localhost v hosts
Kód: [Vybrat]
# cat /etc/hosts
127.0.0.1       localhost

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

3
Kód: [Vybrat]
$ help ulimit
ulimit: ulimit [-SHacdefilmnpqrstuvx] [limit]
    Modify shell resource limits.
   
    Provides control over the resources available to the shell and processes
    it creates, on systems that allow such control.
   
    Options:
      -S        use the `soft' resource limit
      -H        use the `hard' resource limit
      -a        all current limits are reported
      -b        the socket buffer size
      -c        the maximum size of core files created
      -d        the maximum size of a process's data segment
      -e        the maximum scheduling priority (`nice')
      -f        the maximum size of files written by the shell and its children
      -i        the maximum number of pending signals
      -l        the maximum size a process may lock into memory
      -m        the maximum resident set size
      -n        the maximum number of open file descriptors
      -p        the pipe buffer size
      -q        the maximum number of bytes in POSIX message queues
      -r        the maximum real-time scheduling priority
      -s        the maximum stack size
      -t        the maximum amount of cpu time in seconds
      -u        the maximum number of user processes
      -v        the size of virtual memory
      -x        the maximum number of file locks
   
    If LIMIT is given, it is the new value of the specified resource; the
    special LIMIT values `soft', `hard', and `unlimited' stand for the
    current soft limit, the current hard limit, and no limit, respectively.
    Otherwise, the current value of the specified resource is printed.  If
    no option is given, then -f is assumed.
   
    Values are in 1024-byte increments, except for -t, which is in seconds,
    -p, which is in increments of 512 bytes, and -u, which is an unscaled
    number of processes.
   
    Exit Status:
    Returns success unless an invalid option is supplied or an error occurs.

4
Všeobecná podpora / Re:automatický kill některých procesů
« kdy: 10. 06. 2011, 11:31:08 »
Kód: [Vybrat]
ps -A -o start_time,pid,command|sort|egrep getdata ti vyhodi potrebne udaje, dotvor si na to skriptik.
H.
A co takhle?
Kód: [Vybrat]
ps -C getdata -o start_time,pid,command

5
Tak jsem vyměnil řádlky

Kód: [Vybrat]
deb http://www.debian-multimedia.org stable main contrib non-free
deb http://www.debian-multimedia.org testing main contrib non-free
deb http://www.debian-multimedia.org sid main contrib non-free

za

Kód: [Vybrat]
deb ftp://ftp.debian-multimedia.org stable main non-free
deb ftp://ftp.debian-multimedia.org testing main non-free
deb ftp://ftp.debian-multimedia.org sid main non-free

a už to funguje. Už vím co tomu je, je to rozbitý.

6
Obsah mojeho sources.list:
Kód: [Vybrat]
deb http://ftp.debian.org/debian experimental main contrib non-free

deb http://ftp.cz.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.cz.debian.org/debian/ stable main contrib non-free

deb http://security.debian.org/ stable/updates main contrib non-free
deb-src http://security.debian.org/ stable/updates main contrib non-free

deb http://ftp.cz.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.cz.debian.org/debian/ testing main contrib non-free

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

deb http://ftp.cz.debian.org/debian/ unstable main contrib non-free
deb-src http://ftp.cz.debian.org/debian/ unstable main contrib non-free

deb http://www.debian-multimedia.org stable main contrib non-free
deb http://www.debian-multimedia.org testing main contrib non-free
deb http://www.debian-multimedia.org sid main contrib non-free

Nemůžu nikde najít z jakého zdroje mám stahovat acroread balíčky. V nových aktualizacích je acroread-debian-files ve verzi 9.4.2 a ten závisí na stejné verzi balíčku acroread jenže ten se mi ukazuje jako nedostupný. Nikde nemůžu najít jaký zdroj mám použít do sources.list, aby se mi balíček zpřístupnil a přitom balíček zjevně existuje: http://pkgs.org/search/?keyword=acroread
Jenže jak to mám udělat, když to nechci stahovat po jednom balíčku a při každé aktualizaci znova. Všechny návody co jsem našel obashují zdroje které už mám.

7
Nicméně zkusil bych ještě do /etc/apt/apt.conf zadat:

Kód: [Vybrat]
APT::Default-Release "testing";
A zkusit to znova. Soubor /etc/apt/preferences nech jak je. Popřípadě zkus použít aptitude místo apt-get.
Tohle už tam dávno mám. Nicméně, jsem zkusil downgrade na stable a to se tvářilo, že funguje. Jenže já jsem přesvědčený, že tam mám nainstalovanou spoustu balíčků z unstable a přesto mi to nechce dowgradovat na testing. Mimochodem nevíte jak poznat v aptitude ze které distribuce je která verze balíčku? Skoro mám chuť zkusit ten stable.

8
Hmm, tak jsem zjistil, že jsem neměl v sources testing ale squeeze, jenže ani tak mi to nechce nic downgradovat.

9
Tenhle návod mi nefunguje, stále se to snaží instalovat balíky z unstable:

Kód: [Vybrat]
# cat /etc/apt/preferences
Package: *
Pin: release a=testing
Pin-Priority: 1100

# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  cmake hpijs-ppds libgtkhtml-editor-common libgtkhtml-editor0 lzop openoffice.org-base-core openoffice.org-core openoffice.org-evolution openoffice.org-report-builder-bin
  openoffice.org-thesaurus-cs openoffice.org-thesaurus-en-us
The following NEW packages will be installed:
  acl gcc-4.5-base git-man libassuan0 libcamel1.2-19 libebook1.2-10 libecal1.2-8 libedata-book1.2-8 libedata-cal1.2-10 libedataserver1.2-14 libedataserverui1.2-11 libfile-which-perl
  libgtkhtml-editor-3.14-0 libgtkhtml-editor-3.14-common liblvm2app2.2 libpackage-stash-xs-perl libraptor2-0 librasqal3 libreoffice libreoffice-base libreoffice-base-core libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge libreoffice-filter-binfilter libreoffice-filter-mobiledev libreoffice-gcj libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-kde libreoffice-math libreoffice-officebean libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-oxygen libreoffice-style-tango libreoffice-writer linux-image-2.6.37-1-amd64
The following packages will be upgraded:
  acpid apache2 apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common binfmt-support binutils binutils-doc bristol bristol-data bsdutils busybox cmake-data desktop-base dhcp3-client
  djvulibre-desktop dmsetup dnsmasq-base eject evince evince-common evolution evolution-common evolution-data-server evolution-data-server-common evolution-exchange evolution-plugins
  evolution-webcal exiftran fio firmware-linux-free foo2zjs foomatic-filters-ppds gir1.0-gtk-2.0 git git-all git-arch git-cvs git-daemon-run git-doc git-email git-gui git-svn gitk gitweb
  gnome-menus gnome-panel gnome-panel-data gnupg gnupg-agent gnupg-curl gnupg2 gpgsm gpgv gstreamer0.10-ffmpeg hpijs hplip hplip-cups hplip-data hplip-doc hplip-gui htop inkscape iputils-ping
  isc-dhcp-client isc-dhcp-common java-wrappers kaffeine kbd keyboard-configuration ledit lib32gcc1 lib32stdc++6 libblkid1 libcap2 libccid libchamplain-0.4-0 libchamplain-gtk-0.4-0 libdc1394-22
  libdevmapper1.02.1 libdjvulibre-text libdjvulibre21 libebackend1.2-0 libegroupwise1.2-13 libevince2 libevolution libfindlib-ocaml libfindlib-ocaml-dev libfreetype6 libfreetype6-dev libgc1c2
  libgcc1 libgdata-common libgdata7 libgfortran3 libglib2.0-0 libglib2.0-bin libglib2.0-dev libgnome-menu2 libgomp1 libgps19 libgtkhtml3.14-19 libhpmud0 libimobiledevice1 libjpeg-progs libjpeg8
  libksba8 liblzo2-2 libmms0 libmpfr4 libnamespace-clean-perl libnspr4-0d libpackage-stash-perl libpam-modules libpam-runtime libpam0g libpanel-applet2-0 libpci3 libpcsclite1 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libpolkit-gtk-1-0 libportaudio2 libpulse-browse0 libpulse-dev libpulse-mainloop-glib0 libpulse0 libraw1394-11 librdf0 librpm1 librpmio1 libsane
  libsane-extras libsane-hpaio libsgutils2-2 libsox-fmt-alsa libsox-fmt-base libsox1b libspectre1 libssl-dev libssl0.9.8 libstdc++6 libtasn1-3 libtest-pod-perl libtotem-plparser17 libunique-1.0-0
  libusbmuxd1 libutempter0 libuuid1 libvorbis-dev libvorbis0a libvorbisenc2 libvorbisfile3 libwebkit-1.0-2 libwebkit-1.0-common libwildmidi1 libwnck-common libwnck22 libxft2 libxml-twig-perl
  libxmlgraphics-commons-java linux-base linux-image-2.6-amd64 linux-libc-dev login lvm2 lynx lynx-cur mobile-broadband-provider-info mount netcat netcat-traditional ocaml-findlib openoffice.org
  openoffice.org-base openoffice.org-calc openoffice.org-common openoffice.org-draw openoffice.org-emailmerge openoffice.org-filter-binfilter openoffice.org-filter-mobiledev openoffice.org-gcj
  openoffice.org-gnome openoffice.org-gtk openoffice.org-help-en-us openoffice.org-impress openoffice.org-java-common openoffice.org-kde openoffice.org-math openoffice.org-officebean
  openoffice.org-style-galaxy openoffice.org-style-oxygen openoffice.org-style-tango openoffice.org-writer openssl os-prober passwd patchutils pax pbuilder pciutils pcscd perltidy pinentry-curses
  pinentry-gtk2 pinentry-qt4 policykit-1 policykit-1-gnome pulseaudio pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils purifyeps
  python-beautifulsoup python-gmenu python-ipy python-mako python-markupsafe python-pysqlite2 python-uno rpm-common rpm2cpio samba-common samba-common-bin sane-utils shared-mime-info smbclient
  sox telepathy-gabble udisks uno-libs3 ure usbmuxd util-linux uuid-runtime x11-xfs-utils x11-xkb-utils x11-xserver-utils
242 upgraded, 43 newly installed, 11 to remove and 0 not upgraded.
Need to get 270 MB/359 MB of archives.
After this operation, 1,362 kB disk space will be freed.
Do you want to continue [Y/n]?
Get:1 http://ftp.cz.debian.org/debian/ unstable/main libreoffice-filter-binfilter amd64 1:3.3.1~rc2-1 [9,158 kB]
Get:2 http://ftp.cz.debian.org/debian/ unstable/main openoffice.org-filter-binfilter all 1:3.3.0-6 [120 kB]                                                                                         
Get:3 http://ftp.cz.debian.org/debian/ unstable/main openoffice.org-draw all 1:3.3.0-6 [120 kB]                                                                                                     
Get:4 http://ftp.cz.debian.org/debian/ unstable/main openoffice.org-calc all 1:3.3.0-6 [120 kB]                                                                                                     
Get:5 http://ftp.cz.debian.org/debian/ unstable/main openoffice.org-base all 1:3.3.0-6 [120 kB]                                                                                                     
Get:6 http://ftp.cz.debian.org/debian/ unstable/main openoffice.org-writer all 1:3.3.0-6 [120 kB]                                                                                                   
Get:7 http://ftp.cz.debian.org/debian/ unstable/main ure amd64 1.7.0+LibO3.3.1~rc2-1 [1,795 kB]                                                                                                     
Get:8 http://ftp.cz.debian.org/debian/ unstable/main uno-libs3 amd64 1.7.0+LibO3.3.1~rc2-1 [1,620 kB]                                                                                               
Get:9 http://ftp.cz.debian.org/debian/ unstable/main libreoffice-common all 1:3.3.1~rc2-1 [20.0 MB]                                                                                                 
8% [9 libreoffice-common 8,694 kB/20.0 MB 43%]                                                                                                                                     775 kB/s 5min 20s

10
Volná diskuze / Re: KDE vs. GNOME (kdo co a proč?)
« kdy: 13. 10. 2010, 23:16:44 »
Já na experimentování moc nejsem, ale teď když jsem instaloval nový systém na notebook tak jsem taky zkusil GNOME a taky jsem narazil. Prostě jsem nebyl schopen přijít na to jak se co nastavuje. Z KDE jsem zvyklý, že když chci něco nastavit, tak prostě v příslušném místě kliknu pravím tlačítkem a s velkou pravděpodobností se doklikám k nějakému nastavení. V GNOME jsem prostě narazil. Když chci něco nastavit, tak kvůli tomu nehodlám číst manuál. V KDE to sice taky nejde, například když mi nedovolil z nějakého důvodu nastavit scrolování dvěma prsty na touchpadu, ale to spravil xinput. Takových případů je pro mě v KDE mnohem méně a tak mi vyhovuje mnohem víc.

11
Správa a instalace softwaru / Re: Jak ubalit jaderný modul?
« kdy: 12. 10. 2010, 23:38:50 »
Moc se omlouvám, že jsem takový kverulant, ale modul nainstalovat umím. Kupodivu pánové v Realteku to dokázali napsat, tak že make install udělal co měl. Mě šlo spíše o to jak z toho udělat deb. Ale asi se na to vykašlu, nesmím být takový puntičkář. Udělat make clean && make && make install po každém upgrade jádra nakonec nebude takový problém, abych se tím trápil. Teda doufám, že napsali taky dobře i to make clean ;-)

12
Volná diskuze / Re: Jak dlouho jste bez reinstalace?
« kdy: 11. 10. 2010, 23:33:56 »
Tak já jsem našel na domácím desktopu 2005-03-02 což by tak zhruba odpovídalo. Musel jsem se tam trochu poštrachat, protože 2007-03-03 jsem to přesouval na nový HD a tak mám většinu timestampů zničenou. Jinak notebook, ze kterého tohle právě píšu 2007-11-03. A nová T410s tam bude mít 2010-10-09. Osobně vyznávám, že na to přece používám Debian, abych nemusel pořád přeinstalovávat. Jenže po tom co jsem viděl jak vypadá nový Squeeze out of the box, tak si říkám že jednou za tři roky by nemuselo být až zas tak moc často. Na ten desktop už to asi nemá cenu, protože ten HW už poněkud přesluhuje a budu muset přijít nová instalace na nový HW. Už když jsem to tam dával, tak to byl vysloužilý server.

13
Správa a instalace softwaru / Re: Jak ubalit jaderný modul?
« kdy: 11. 10. 2010, 23:06:48 »
Tak já na moduly poštvu příkaz:
Kód: [Vybrat]
m-a a-i
a je to. Za předpokladu, že máš nainstalovaný balíček "module-assistant"

a pak příkazem
Kód: [Vybrat]
modprobe s patřičnými parametry natáhnu. Byl jsem možná moc rychlý a možná nepřesný, pokud by bylo potřeba něco dalšího, tak jsem k dispozici.

Kód: [Vybrat]
# m-a list | grep '^r'
rt2400-source (source package not installed):
rt2500-source (source package not installed):
rt2570-source (source package not installed):
rtai-source (source package not installed):
Nechci být jízlivý, ale možná by pomohlo si pozorně přečíst dotaz.
Používám Squeeze a potřebuji ubalit rtl8192se_linux_2.6.0017.0705.2010.tar.gz
Podpora v module-assistant pro tohle není. Abych se přiznal, tak balení deb je pro mě španělskou vesnicí.

14
Volná diskuze / Re: 32-bit | 64-bit
« kdy: 11. 10. 2010, 21:35:28 »
Používám 32bit, ale teď zrovna se snažím rozchodit 64 na nové ThinkPad T410s. ... Takže do těch 64b asi půjdu, ale dře to.
Takže flash jede, Adobe Acrobat jede, zvuk jede, video jede, skype jede. Asi už u toho zůstanu. Já dělám hodně serverové věci a některé věci se na 64b dělají snáz. Prostě si namapovat pár GB virtuální paměti a nechat OS ať se s tím popere je jednodušší než se prát s adresovacím limitem. To samé mmap a tak. Na desktopu to asi normálně pro lidi význam nemá, ale pro mě je jednodušší vyvíjet ve stejném prostředí jako cílová platforma.

15
Správa a instalace softwaru / Jak ubalit jaderný modul?
« kdy: 09. 10. 2010, 17:11:56 »
Ahoj, může mi někdo poradit jak se dá udělat balíček pro jaderný modul. Moc děkuji za pěkné návody k balení jádra, ale nikde nemůžu nají debian way jak by se mělo dělat tohle. Všude nacházím jen návody jak si ubalit nové jádro, jak si ubalit jaderné moduly co jsou dodávané s jádrem, nebo jak k jaderným modulům přidat svůj modul, ale já bych rád jen udělal balíček s jedním jaderným modulem a používal distribuční.

Používám Squeeze a potřebuji ubalit rtl8192se_linux_2.6.0017.0705.2010.tar.gz
Podpora v module-assistant pro tohle není. Abych se přiznal, tak balení deb je pro mě španělskou vesnicí.

Stran: [1] 2 3 4