Autor Téma: PSX  (Přečteno 3901 krát)

gekoncze

  • Host
PSX
« kdy: 28. 07. 2011, 16:37:30 »
Ahoj
Mám problém se spuštěním emulátorů playstation her (epsxe a pcsx).

Když spustím epsxe 1.6.0 (linux), tak mi to napíše tuto hlášku:
./epsxe: error while loading shared libraries: libgtk-1.2.so.0: cannot open shared object file: No such file or directory
Nekde jsem četl, že je tato knihovna už moc stará, tak nevim kde ji sehnat. Také jsem zkoušel spustit tento program pomocí wine. Sice se spustí, ale nevidí žádné pluginy.

Když spustím pcsx, tak mi to napíše tuto hlášku:
./pcsx: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
když jsem tuto knihovnu hledal ve svém pc, tak jsem ji našel v "/usr/lib". Tak nevim, jestli ji mam někam zkopirovat nebo co s tim...

os: debian-6.0.2.1-amd64-CD-1
budu rád za jakoukoli radu, protože psx hry tvoří asi 90% všech her co hraju  :D

Offline Hobild

  • Uživatel
  • ***
  • Příspěvků: 233
    • Zobrazit profil
  • Jabber: hobil@jabber.root.cz
Re:PSX
« Odpověď #1 kdy: 28. 07. 2011, 18:19:55 »
Budu predpokladat, ze mas squeeze, stable:
libgtk-1.2.so.0 v repozitarich opravdu neni, je stara.
libgtk-x11-2.0.so.0 je v balicku libgtk2.0-0, predpokladam, ze ten mas nainstalovany.
Programy epsxe a pcsx v repozitarich nejsou.
Emulator playstation je v balicku pcsxr, ve verzi: 1.9.92-3, mas na mysli ten? Ten obsahuje spustitelny soubor /usr/games/pcsx.

Predpokladam, ze problem bude v namichani stable a testing verzi, kdy doslo k povyseni nekterych knihoven, ale nektere programy s tim nepocitaji. Stalo se mi neco podobneho s mplayerem (stable), ktery nesel spustit po odinstalovani mplayeru (testing). Teprve po reinstalu/downgradu knihoven z testing na stable to zacalo fungovat OK. Pokud to tak je, bude to vyzadovat trochu rucni prace s vysledovanim zavislosti a jejich napravou.

gekoncze

  • Host
Re:PSX
« Odpověď #2 kdy: 29. 07. 2011, 21:52:44 »
Tak jsem zkusil nainstalovat pcsxr, ale také nefunguje... pro epsxe jsem tu knihovnu našel (libgtk-1.2), ale i po její instalaci ji to nenajde... nejlehčí to bude asi spouštět přes virtualbox windows verzi.