Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Témata - bhy

Stran: [1]
1
Správa a instalace softwaru / TeXLive 2008
« kdy: 20. 07. 2009, 13:08:23 »
Ti z nás, co píštou v (Xe)(La)TeXu a používají Debian, vědí, že v Debianu je stále jen TeXLive 2007, v mnoha ohledech už zastarávající (chybí polyglossia, unicode-math atd.), a že TeXLive 2008 pro Debian je v nedohlednu, spíš se rovnou počká na 2009 a kdoví kdy ta bude (v Debianu). Jde o to, že TeXLive má vlastní package management a naroubovat jej na Apt není nejsnazší. Jde taky samozřejmě nainstalovat TeXLive 2008 ručně, mimo Apt, jenže pak Apt neví o její přítomnosti, a když chcete něco k TeXu z Aptu, třeba Kile, bude to chtít doinstalovávat kopu závislostí z TeXLive 2007, které už máte v novější verzi, jen Apt o nich neví.

Řešili jste někdo úspěšně tuto situaci? Máte TeXLive 2008 v Debianu a netrápíte se s dependencemi? Máte nějaká doporučení? Díky moc.

2
Pěkný den přeju. Všiml jsem si, že v experimentalu se začíná objevovat KDE 4.3 beta, označené jako 4.2.96. Rozhodl jsem se ho zkusit. Všechno funguje, až na to, že některé balíky asi zatím chybí, např. kscreensaver. Ten závisí na balíku kdebase-workspace-libs4+5, který je dostupný zatím jen ve verzi 4.2.4. (Tzn. kscreensaver lze nainstalovat jen za cenu downgrade KDE zpět na 4.2.4.) Nepovedlo se vám to někomu nějak obejít? Např. doinstalováním nějakých balíků z NEW (těch co ještě nejsou v experimental.. ale nevím, odkud je stáhnout) nebo z kubuntu? :) díky.

Kód: [Vybrat]
debian:/home/bhy# aptitude install -t experimental kscreensaver
Čtu seznamy balíků... Hotovo                                   
Vytvářím strom závislostí                                     
Čtu stavové informace... Hotovo                               
Čtu rozšířené stavové informace                               
Inicializuji stavy balíků... Hotovo                           
Následující balíky jsou PORUŠENY:                             
  libkephal4 libkfontinst4 libkscreensaver5 libksgrd4 libkworkspace4 libnepomukquery4 libnepomukqueryclient4 libplasma-applet-system-monitor4 libplasma-geolocation-interface4 libplasmaclock4
  libprocesscore4 libprocessui4 libsolidcontrol4 libsolidcontrolifaces4 libtaskmanager4 libweather-ion4                                                                                       
Následující NOVÉ balíky budou instalovány:                                                                                                                                                     
  kdebase-workspace-libs4+5{a} kscreensaver kscreensaver-xsavers{a} libgle3{a} xscreensaver-data-extra{a} xscreensaver-gl{a} xscreensaver-gl-extra{a}                                         
0 balíků aktualizováno, 7 nově instalováno, 0 k odstranění a 7 neaktualizováno.                                                                                                               
Potřebuji stáhnout 9277kB archivů. Po rozbalení bude použito 25,6MB.                                                                                                                           
Následující balíky mají nesplněné závislosti:                                                                                                                                                 
  libkworkspace4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                     
  libplasma-geolocation-interface4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                   
  libplasmaclock4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                     
  libweather-ion4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                     
  libprocessui4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                       
  libprocesscore4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                     
  libsolidcontrol4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                   
  libnepomukquery4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                   
  libsolidcontrolifaces4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                             
  libksgrd4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                           
  libtaskmanager4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                     
  libkephal4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                         
  libnepomukqueryclient4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                             
  libkscreensaver5: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                   
  libkfontinst4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                                       
  libplasma-applet-system-monitor4: Koliduje s: kdebase-workspace-libs4+5 (< 4:4.2.90) ale 4:4.2.4-1+b1 se bude instalovat.                                                                   
Následující akce vyřeší tyto závislosti:                                                                                                                                                       

Ponechat následující balíky v jejich aktuální verzi:
kdebase-workspace-libs4+5 [Nenainstalovaný]         
kscreensaver [Nenainstalovaný]                     

Ponechat následující závislosti nevyřešené:
kscreensaver-xsavers doporučuje kscreensaver (= 4:4.2.4-1)
Tier: Safe actions (10000)

Přijmout toto řešení? [Y/n/q/?] q
Končím všechny snahy na vyřešení těchto závislostí.
Přerušeno.

3
mělo by se něco udělat s přístupem redakčního systému k tomu, když chce někdo komentovat příspěvky na úvodní stránce. pod příspěvkem o MONO jsem založil komentář, kde byly odkazy na čtyři články k tématu. komentář mi to nevzalo, zřejmě byl nesmyslně vyhodnocen jako spam a to i když jsem k odkazům přidal text. zatímco jeden odkaz v jednom komentáři je zřejmě akceptovatelný i bez doprovodného textu. tedy jsem odkazy vkládal po jednom a v jednu chvíli mi to vynadalo, že vkládám komentáře příliš rychle a mám zpomalit! co to proboha je?! místo aby se systém uživateli omluvil, že je pomalý, ještě svaluje vinu na něj, přijde mi to jako drzost.
čtenář chce vložit komentáře k tématu, které mají smysl pro ostatní čtenáře (někdy je to i jeho právo, když jsou informace v původním příspěvku neobjektivní), a jsou mu takhle blbě házeny klacky pod nohy. mrzí mě takové bránění šíření informací na webu věnovaném svobodnému operačnímu systému.

Stran: [1]