Debian fórum

Dotazy => Získání a instalace Debianu => Téma založeno: emil54 26. 05. 2009, 17:08:56

Název: testing s 2.6.28
Přispěvatel: emil54 26. 05. 2009, 17:08:56
Ahoj.
chtel jsem se po trech mesicich s Ubuntu 8.10 a 9.04, kam jsem utekl po neresitelnejch problemech s HW na stable verzi Lennyho (problemy s DNS resolvingem v aplikacich a prapodivnym chovanim systemovyho casu - zelezo: Acer Ferrari 4000), vratit zpet na Debian.
Stahl jsem si debian-testing-amd64-netinst.iso a predpokladal (nekde jsem to tu i cetl), ze uz pojede na jadru 2.6.28. Takze jsem asi neco blbe pochopil, kdyz mam jadro 2.6.26?

Kdyz tak koukam do systemu, tak tam toho zatim novyho moc neni - oproti Lennymu, jak si ho pamatuju. A ten kernel mi stve, ponevadz jsem se tesil, ze s novym jadrem by mohly pominout ty popisovany problemy. Bohuzel, je to tu zas a uplne stejne.

Chtel bych se proto zeptat, jak co nejjednodussim zpusobem dostat do systemu novejsi jadro, abych si nakonec este nepridelal dalsi zbytecny problemy.

A nebo este jina otazka: co je v Debianu v souvislosti se siti a podporou HW az tolik odlisnyho, ze v Ubuntu to funguje normalne, ale tady mi treba Icev., Opera, Apt, Aptitude a dalsi aplikace, ktery pracujou s internetem, cca 7 az 10 sekund hrabou na DNS, nezli zacnou tahat data, pricemz ping z terminalu na domenu resolvne IP bleskove?

Budu skutecne vdecnej za jakejkoli napad, protoze bych se nerad znovu vracel na Ubuntu. Ubuntu mam sice docela rad, ale proti odladenymu debianu je moc rozezrany a pomaly.
Název: Re: testing s 2.6.28
Přispěvatel: Jakub Lucký 26. 05. 2009, 17:46:01
Chápu, že je prostě problém s tím, že chcete novější jádro?

Já za sebe doporučuji kompletní upgrade na unstable, testing je o ničem (staré balíky a žádná výhoda), ale nutit vás do toho nemůžu
Pokud ne, pak zkuste pouhý upgrade kernelu:
Kód: [Vybrat]
přepsat sources list z testing na unstable
apt-get update
apt-get install linux-image-2.6-29-2-686 (nebo amd64, dle libosti a HW)
Pokud budete dělat modul pro nvidii, pak ještě
Kód: [Vybrat]
apt-get install linux-headers-2.6.29-2-686 (nebo amd64, viz výše)
apt-get install linux-headers-2.6.29-2-common
apt-get install linux-kbuild-2.6.29
Název: Re: testing s 2.6.28
Přispěvatel: tlamic 26. 05. 2009, 20:33:06
Vám funguje unstable bez problémů?
Název: Re: testing s 2.6.28
Přispěvatel: Ota Trkola 26. 05. 2009, 20:51:25
Mám sice rád aktuální balíčky, ale zároveň i určitou míru stability. Proto bych do unstable nešel. Podle mně je právě testing rozumným kompromisem. Pravda je, že jádro by mohlo být v testingu aktuálnější.
Název: Re: testing s 2.6.28
Přispěvatel: emil54 26. 05. 2009, 21:23:41
:D tak uz pisu z Widli a i ty se chovaji hooodne prapodivne. Asi mi jde notas do kytek...

Jinak diky za typ.
Jestli se mi to este povede rozbehnout (chystam se notysek opet rozebrat), tak to prubnu.
Posledni, co jsem udelal, bylo vypnuti kvuli bource - pak uz nenabehnulo gdm a neslysi to na zadny osvedceny kouzla. Pritom pred tim nekolik restartu v pohode a nic jsem nemenil, neinstaloval... Asi skutecne HW chyba. No co uz, nic netrva vecne :)
Název: Re: testing s 2.6.28
Přispěvatel: Jakub Lucký 26. 05. 2009, 21:28:51
Mám sice rád aktuální balíčky, ale zároveň i určitou míru stability. Proto bych do unstable nešel. Podle mně je právě testing rozumným kompromisem. Pravda je, že jádro by mohlo být v testingu aktuálnější.

Já nevím, jak jste zkoušel unstable vy, ale já na něm jedu rok a půl a zatím žádný problém, který by způsobil: nenaběhnutí graf. rozhraní (s novým jádrem nutno udělat nový modul pro nvidii, ale to stejně tak v testingu a stable) ani aplikaci, která by se upgradem rozbila do nepoužitelnosti...

Unstable neznamená nestabilní, ale nevyzkoušený důkladně
Název: Re: testing s 2.6.28
Přispěvatel: Erich Stark 26. 05. 2009, 23:13:32
Vám funguje unstable bez problémů?

Dva krat som ho skusal a dva krat problemy :D
to sa mi stalo pri gnome ked som upragoval na sida potom mi uz nenabehlo gnome iba nejake zelene graf rozhranie, tak som to potom nechal tak, ale to som bol este mlady a sprosty :)
ale teraz uplna spokojnost s debian lenny kde 3.5.10 a jadro 2.6.29 z unstable,
ale rozmyslam upgrade na squeeze je tam kde 4.2.2, mno uvidime ;)
Název: Re: testing s 2.6.28
Přispěvatel: Jakub Lucký 27. 05. 2009, 00:01:54
Jediné, co musí člověk při používání Unstable umět je číst, jestli se náhodou aptitude (proto ho nemám rád) nesnaží nějaké balíky při upgrade odebrat...

Já osobně proto radši používám apt-get a řeším závislosti ručně a rok a půl s unstable (z toho rok a půl mixnutý s experimentalem půl na půl) bez jakýchkoliv obtíží...
Název: Re: testing s 2.6.28
Přispěvatel: emil54 27. 05. 2009, 00:59:20
Hm, tak jsem zas na Ubuntu :(
Ted na to uz nemam kdy - musim tvorit hodnoty. Zkusim po nedeli novou instalaci na jinej disk, protoze mi to nejde do palice. Uz je to podruhy, co to vzdavam s totalne rozhasenym Debianem, pricemz na Ubuntu jde v podstate totozna konfigurace naprosto bez problemu. Jenom to jadro je tu 2.6.28, Ale bez problemu mi slo Ubuntu i s jadrem 2.6.26, jestli si to dobre pamatuju (II). Nejspis trochu odlisne postavena HW podpora...

No nic, zatim dik za pozornost :)
Název: Re: testing s 2.6.28
Přispěvatel: bhy 29. 05. 2009, 08:56:47
hm.. rozdíly v podpoře HW mezi debianem a ubuntu by být neměly.. spíš jde o odlišnou výchozí konfiguraci něčeho.
Název: Re: testing s 2.6.28
Přispěvatel: Jakub Lucký 29. 05. 2009, 13:00:26
Ale jo, jsou tam... pokud se nepletu, mají trošku jiný .config a hlavně dodávají linux-restricted-modules, které si v Debianu musí člověk udělat sám...
Název: Re: testing s 2.6.28
Přispěvatel: emil54 31. 05. 2009, 23:34:01
No, ja jsem si predevsim komplikoval zivot origo ovladacema na grafiku ATI X700 ze stranek AMD. Pod dojmem starejch zkusenosti, ze vzdy stacilo stahnout nejnovejsi verzi a vsechno slapalo, jsem to ted pokazdy udelal taky, jenomze pak jsem zjistil, ze uz tahle karta vubec neni podporovana a nema uz podporu ani ve verzi ati-driver-installer-9-3-x86.x86_64.run pro novejsi jadra, prestoze je v changelogu psano, ze jo (mozna ze jsem neco prehlidnul). Instalace sice probehne korektne, ale pri volani aticonfig rve, ze nebylo nalezeno podporovane zarizeni, ci tak neco. Takze s grafikou mam pech. A bohuzel, to byl jedinej lek na problemy, ktery mi HW delal uz na Lennym v dobe, kdy byl ve stadiu testing (rozhozenej systemovej cas, tuhnuti grafiky, prip. celyho systemu atd...). Pokud jsem nainstaloval ty proprietarni ovladace, tak si to sedlo. Jenze v momente, kdyz Lenny dostal nalkepku "stable", pri prvnim vetsim update se mi to rozsypalo. Mozna, kdybych se neukvapil a zkusil to nejak poladit, bylo by vse pouzitelny dal. Jenomze ja chtel novou instalaci... A tim jsem asi s Debianem na tomhle notasu skoncil.
Proto jsem se pidil po jadru 2.6.28, ze na 9.04 Ubuntu to jede vcelku slusne, vcetne jakystakys podpory opengl akcelerace, hned po instalaci a s free ovladacema.

Jsem ted docela v presu, nestiham nic, takze se na to asi hnedtak nedostanu, ale vzdavat to nehodlam - urcite nejaky reseni existuje :)
Název: Re: testing s 2.6.28
Přispěvatel: Boogey 04. 06. 2009, 01:53:37
Zdravim, zkus kdyztak tyto ovladace.

http://support.amd.com/us/gpudownload/linux/legacy/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.18&lang=English

Název: Re: testing s 2.6.28
Přispěvatel: eXt_r33m 26. 07. 2009, 15:36:00
Jediné, co musí člověk při používání Unstable umět je číst, jestli se náhodou aptitude (proto ho nemám rád) nesnaží nějaké balíky při upgrade odebrat...

Já osobně proto radši používám apt-get a řeším závislosti ručně a rok a půl s unstable (z toho rok a půl mixnutý s experimentalem půl na půl) bez jakýchkoliv obtíží...
Ehm zabudl jste na safe-upgrade ;) nejprv man az potom psat :D
Název: Re: testing s 2.6.28
Přispěvatel: Jakub Lucký 26. 07. 2009, 17:19:19
No, já aptitude nepoužívám ani jsem nikdy nepoužíval, takže moje chyba je dost pravděpodobná... Firemní servery používají dselect, já osobně řeším věci ručně přes apt...
Název: Re: testing s 2.6.28
Přispěvatel: eXt_r33m 26. 07. 2009, 17:37:15
No, já aptitude nepoužívám ani jsem nikdy nepoužíval, takže moje chyba je dost pravděpodobná... Firemní servery používají dselect, já osobně řeším věci ručně přes apt...
Wow ted pri instalaci sem si uzil sve... ja zase nevedel o dist-upgrade takze zo stable na testing to slo pekelne tezko :D