Dotazy > Správa a instalace softwaru

Skype na debiane

(1/2) > >>

Erich Stark:
Zdravim už ste skušali na debiane alebo .deb systeme vseobecne? Mam s tym problemy,stahol som ho z ofc stranky a nainstlaoval,vsetko prebehlo v poriadku. Ale neviem ako rozbehnut mikrofon nemozem nikomu zavolat lebo to pise nejaku blbu hlasku s audioplaybackom.
Popripade som skusal rozbehnut najnovsi skype na windows cez wine ale to nejak nefachalo :-D

tom.i:
Jukl ses v nastaveni skype, jestli mas spravnej vystup a vstup, pak jestli nemas MUTE na mikrofonu. Jetli mas vse zapojeno dobre a tak.. milion pricin ;)

airlive:
1. Nainstalovat balíky:
gstreamer0.10-pulseaudio
libao-pulse
libsdl1.2debian-pulseaudio (tento nahradí balík libsdl1.2debian-alsa)
libasound2-plugins
libflashsupport

2. Zapnout podporu Pulse Audia pro aplikace používající GStreamer: v Systém > Volby > Zvuk vybrat u všeho PulseAudio
3. Aby ALSA používala PA, stačí příkaz asoundconf set-pulseaudio
4. V souboru /etc/libao.conf změnit řádek default_driver z alsa na pulseaudio

Teď by všechny aplikace měly používat PulseAudio, mě to pomohlo, hraje mi teď vše, co jsem zkoušel. Původní postup je na http://ubuntuforums.org/showthread.php?t=711274

airlive:
2)
1. Zazálohujte si /etc/pulse/default.pa
2. Otevřete /etc/pulse/default.pa v nějakém editoru, před řádek "load-module module-hal-detect" napište # (zakomentujte ho), a na konec souboru přidejte řádky

--- Kód: ---load-module module-alsa-sink device=dmix sink_name=output
load-module module-alsa-source device=dsnoop
--- Konec kódu ---
(Ony už tam sice jsou, ale zakomentované a ne celé.)
3. Do souboru ~/.asoundrc přidejte

--- Kód: ---pcm.skypeout {
type plug
slave.pcm "dmix"
}
ctl.skypeout {
type hw
card 0
}
pcm.skypein {
type plug
slave.pcm "dsnoop"
}
ctl.skypein {
type hw
card 0
--- Konec kódu ---
4. Ukončete PulseAudio a znovu ho spusťte:

--- Kód: ---killall pulseaudio
pulseaudio &
--- Konec kódu ---
5. Spusťte Skype, v Options vyberte Sound Devices. Pro Sound Out a Ringing vyberte zařízení skypeout, pro Sound In vyberte skypein. Restartujte Skype a mělo by to fungovat.

Zkoušel jsem sice jenom zkušební hovor, ale ten šel. Pokud se cokoli pokazí, obnovte /etc/pulse/default.pa z vaší zálohy a znovu spusťte PulseAudio (bod 4).

Petr Slunský:
airlive:
myslím, že by to mohlo jít i jednodušeji. Podle mě je důležité správně zvolit hw vstupní a výstupní zařízení, mít ovladač zvukovky s podporou mikrofonu, nastavit úroveň mikrofonu a mělo by to jet. (i bez výměny alsy)

Navigace

[0] Seznam témat

[#] Další strana

Přejít na plnou verzi