Autor Téma: Chybajuce baliky v repo  (Přečteno 3807 krát)

Offline Erich Stark

  • Aktivní­ uživatel
  • ****
  • Příspěvků: 546
    • Zobrazit profil
Chybajuce baliky v repo
« kdy: 08. 10. 2010, 10:09:38 »
Skusal som debi squeezeho a v repozitaroch som nenasiel balik ktory potrebujem, a myslim si ze ich tam este asi chyba viac, kedy budu vsetky baliky prekompilovane aj do squeezeho?
" The box said that I needed to have Windows XP or better ... so I installed Debian ."

Offline Roman Horník

  • Hlavní moderátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.326
    • Zobrazit profil
  • Jabber: roman.hornik@jabber.cz
Re: Chybajuce baliky v repo
« Odpověď #1 kdy: 08. 10. 2010, 10:32:53 »
Máš na mysli nějaký konkrétní?
Debian Sid 64bit + Mate Desktop Environment
* CPU: Intel Pentium G2020
* GPU: NVIDIA GTX650 1GD5
* MB: Lenovo IH61M
* RAM: 16GiB Deutsche Demokratische Republik 3

Offline Petr Krčmář

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 448
    • Zobrazit profil
    • Debian-linux.cz
Re: Chybajuce baliky v repo
« Odpověď #2 kdy: 08. 10. 2010, 12:26:21 »
Squeeze obsahuje všechny balíky, které se dostanou do finálního vydání. Už je hluboce zmrazen, takže už nedochází k žádným změnám kromě těch, které opravují nějaké chyby. Balíky se do testingu nikdy nedostávají nárazově těsně před vydáním, ale neustále se točí a jednou za dva roky se to zamrazí. Žádné nárazové přidávání velkého množství balíčků tam neprobíhá. Jaký balík ti chybí?

Offline Erich Stark

  • Aktivní­ uživatel
  • ****
  • Příspěvků: 546
    • Zobrazit profil
Re: Chybajuce baliky v repo
« Odpověď #3 kdy: 08. 10. 2010, 18:45:13 »
konkretne mne chyba http://packages.debian.org/sid/netbeans-ide , na stranke je vediet ze je len v lenny a sid, a takisto mi nesiel ani nainstalovat, viem ze si ho mozem stihanut z webu a nainstalovat rucne, ale mam radsej distribucne baliky a kedze chyba tento tak ma napadlo ze ich bude asi chybat viac, a nechapem preco v sidovi je len 6.0.1 ked uz je davno vonku 6.9.1
" The box said that I needed to have Windows XP or better ... so I installed Debian ."

Offline Erich Stark

  • Aktivní­ uživatel
  • ****
  • Příspěvků: 546
    • Zobrazit profil
Re: Chybajuce baliky v repo
« Odpověď #4 kdy: 11. 10. 2010, 11:09:13 »
tak co si myslite preco sa tam asi neobjavil, popripade je moznost ze by sa objavil, neviem ci to treba nahlasit alebo .. ?
" The box said that I needed to have Windows XP or better ... so I installed Debian ."

Offline Erich Stark

  • Aktivní­ uživatel
  • ****
  • Příspěvků: 546
    • Zobrazit profil
Re: Chybajuce baliky v repo
« Odpověď #5 kdy: 11. 10. 2010, 16:13:08 »
už mám odpoveď :)

"On Mon, Oct 11, 2010 at 11:16:55AM +0200, EriNo72 wrote:
> Good day, i would like to ask why netbeans isn't in squeeze repository.
>
>
The package has a release critical bug, meaning that without that bug
being fixed, the package cannot be released. For details:

http://bugs.debian.org/cgi-bin/pkgreport.cgi?src=netbeans-ide

If that bug were fixed, then it would possibly be allowed to propogate
back into squeeze.

Regards,

-Roberto

--
Roberto C. Sánchez
http://people.connexer.com/~roberto
http://www.connexer.com"
" The box said that I needed to have Windows XP or better ... so I installed Debian ."

Offline borek

  • Nováček
  • *
  • Příspěvků: 8
    • Zobrazit profil
Re: Chybajuce baliky v repo
« Odpověď #6 kdy: 11. 10. 2010, 19:56:28 »
Netbeans v debianu je problém. Nové verze se tam nedostala už pěkně dlouho a navíc poslední změna byla, že netbeans závisí na OpenJDK a ne na libovolné javě. Já netbeans instaluju z oficiálního balíku na netbeans.org a instaluju do /opt. Funguje to bez problémů, akorát si nové verze musím hlídat sám. Jinak nevýhoda té verze 6.0.1 je její neskutečná pomalost. Kromě toho v kombinaci s OpenJDK jsem narazil na problém(možná je opravený už jsem to dlouho nezkoušel), že pokud se do konzole vypisovalo větší množství zpráv, tak při skrolování nebyli čitelné.

Offline Erich Stark

  • Aktivní­ uživatel
  • ****
  • Příspěvků: 546
    • Zobrazit profil
Re: Chybajuce baliky v repo
« Odpověď #7 kdy: 12. 10. 2010, 14:11:14 »
Netbeans v debianu je problém. Nové verze se tam nedostala už pěkně dlouho a navíc poslední změna byla, že netbeans závisí na OpenJDK a ne na libovolné javě. Já netbeans instaluju z oficiálního balíku na netbeans.org a instaluju do /opt. Funguje to bez problémů, akorát si nové verze musím hlídat sám. Jinak nevýhoda té verze 6.0.1 je její neskutečná pomalost. Kromě toho v kombinaci s OpenJDK jsem narazil na problém(možná je opravený už jsem to dlouho nezkoušel), že pokud se do konzole vypisovalo větší množství zpráv, tak při skrolování nebyli čitelné.

Vidis nejaky rozdiel v rychlosti alebo v niecom inom na OpenJDK alebo jave od sun? A preco to instalujes do /opt
" The box said that I needed to have Windows XP or better ... so I installed Debian ."

Offline borek

  • Nováček
  • *
  • Příspěvků: 8
    • Zobrazit profil
Re: Chybajuce baliky v repo
« Odpověď #8 kdy: 12. 10. 2010, 16:06:51 »
Do /opt instaluju, protože /opt nespravuje apt, takže si nedělám bordel v systému. Programy, které nejsou instalované pomocí balíkovacího systému, je vždy lepší uklidit někam stranou.

Rozdíl v rychlosti mezi OpenJDK a SUN JDK není znatelný, pouze asi před rokem a půl, když jsem to naposled zkoušel, byl problém s překreslováním swingu. To už ale nejspíš bude opravené. Pokud instaluješ z oficiálních balíků z netbeans.org, můžeš si vybrat co chceš použít. Navíc v netbeans si můžeš registrovat obě JDK a přepínat si mezi nimi až u jednotlivých projektů.