Autor Téma: Problem s anglickou klávesnicí [vyřešeno]  (Přečteno 2858 krát)

Offline Avathar

  • Začátečník
  • **
  • Příspěvků: 21
    • Zobrazit profil
Problem s anglickou klávesnicí [vyřešeno]
« kdy: 01. 06. 2009, 13:47:13 »
Vyskytl se mi vcelku nepříjemný problém s klávesnicí.

V xorg.conf jsem si nastavil přepínání s české klávesnice na anglickou tímto zpusobem:

Kód: [Vybrat]
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "cz,us"
Option "XkbOptions" "grp:alt_shift_toggle"
EndSection

Po restartu klávesnice krsáně přepíná, všechno píše jak má ... avšak, vyskytl se jeden problém.

Když píšu nějaký kód např pro c++ a pak to dám skompilovat hodí mi to errory typu:

Kód: [Vybrat]
error: stray ‘\240’ in program
Což znamená že mám v tom kódu nějaké nepřípustné znaky.  No a pruser je právě v tom, že ty špatné znaky mi tam asi háže klávesnice, právě když ji mam zapnutou v anglickem režimu.

Když ten kód skusím odklepat českou klávesnici, nebo ho odněkud skopčit ..tak kompiluje vše v pořádku.
Skoušel jsem ruzne editory ..mousepad, vim, emacs, scite..  dělá to ve všech..když zapnu anglickou klávesnici.

Netušíte jak by se to dalo napravit? Někde jsem něco četl že se da klavesnice nějak přemapovat..ale hrom se v tom vyznej, jak mam poznat které ty znaky jsou vlastn nepřípustné, když je ani nevidím.

BTW:  s řádkováním LF, CR nebo CRLF jsem skoušel experimentovat...tím to nebude

« Poslední změna: 30. 03. 2010, 18:36:48 od Ota Trkola »

Offline Petr Slunský

  • Uživatel
  • ***
  • Příspěvků: 220
  • Linux user #485524
    • Zobrazit profil
  • Jabber: slunsky@njs.netlab.cz
Re: Problem s anglickou klávesnicí
« Odpověď #1 kdy: 19. 06. 2009, 16:44:07 »
Ahoj. A co takhle nenastavovat přepínání jazyka klávesnice xorg.conf, ale nastavit to v KDE (nebo GNOME). Pro KDE v kcontrol nebo systemsettings.

Debian

Offline Avathar

  • Začátečník
  • **
  • Příspěvků: 21
    • Zobrazit profil
Re: Problem s anglickou klávesnicí
« Odpověď #2 kdy: 25. 03. 2010, 10:41:54 »
@Spox:  Dík za tip, nicméně používám XFCE a žádné okénkové nastavovátka pro nastavení přepínání klávesnice jsem nenašel.

Nicméně, po hodně delší době se mi to konečně podařilo rozchodit. Do konfigurace klávesnice stačily přidat následující řádky:
Kód: [Vybrat]
Option      "CoreKeyboard" "true"
Option      "XkbRules"  "xorg"

Takže celý muj xorg pro klávesnici vypadá tekďka takto:
Kód: [Vybrat]
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "CoreKeyboard" "true"
   Option      "XkbRules"  "xorg"
   Option      "XkbModel"  "pc105"
   Option      "XkbLayout" "us,cz"
   Option      "XkbOptions"    "grp:alt_shift_toggle"
EndSection

A vše funguje jak má. Už mi to nehází žádné mimozemské znaky.

Offline borek

  • Nováček
  • *
  • Příspěvků: 8
    • Zobrazit profil
Re: Problem s anglickou klávesnicí [vyřešeno]
« Odpověď #3 kdy: 31. 03. 2010, 15:44:49 »
Tahle chyba je způsobena tím, že se místo znaku mezery(0x20) vkládá nedělitelná mezera(0xC2A0). Řešením je přidat volbu Option "XkbOptions"    "nbsp:none". V tvém případě Option      "XkbOptions"    "grp:alt_shift_toggle,nbsp:none"
« Poslední změna: 31. 03. 2010, 15:46:57 od borek »