Autor Téma: aptitude purge  (Přečteno 4521 krát)

Offline johnnycage

  • Začátečník
  • **
  • Příspěvků: 90
    • Zobrazit profil
aptitude purge
« kdy: 13. 11. 2009, 20:47:35 »
Zdravim.

Dnes sa mi aktualizoval balicek sysv-rc a chvilu po upgrade som si vsimol tento clanok:

http://www.debian-linux.cz/debian-squeeze-uz-startuje-podle-zavislosti/

Celkom ma tu zaujalo, ale mam tu jeden problem. Pri spusteni prikazu dpkg-reconfigure sysv-rc mi vypisuje toto:

Kód: [Vybrat]
package smartmontools removed but not purged, package smstools removed but not purged, package wicd removed but not purged
Tak som postupoval podla clanku a zadal prikaz "aptitude purge smartmontools smstools wicd", lenze mi to chce odstranit polovicu systemu:

Kód: [Vybrat]
Nasledujúce balíky sa ODSTRÁNIA:
  abiword-common{u} app-install-data{u} arj{u} avahi-utils{u}
  binfmt-support{u} bogofilter{u} bogofilter-bdb{u} bogofilter-common{u}
  brasero-common{u} cdrdao{u} cli-common{u} clive{u} clive-utils{u}
  deborphan{u} dmraid{u} doc-base{u} dpatch{u} dvd+rw-tools{u} espeak{u}
  espeak-data{u} evince{u} evince-common{u} evolution-webcal{u}
  fast-user-switch-applet{u} festival{u} festlex-cmu{u} festlex-poslex{u}
  festvox-kallpc16k{u} freeglut3{u} gconf-defaults-service{u}
  gconf-editor{u} gdebi{u} gdebi-core{u} gdm{u} gdm-themes{u} gedit{u}
  gedit-common{u} gedit-plugins{u} genisoimage{u} ggzcore-bin{u}
  gnome-app-install{u} gnome-cards-data{u} gnome-mag{u} gnome-pilot{u}
  gnome-pilot-conduits{u} gnome-system-tools{u} gnome-themes-extras{u}
  gnome-themes-more{u} gnome-volume-manager{u} gparted{u}
  gstreamer0.10-gnomevfs{u} gstreamer0.10-tools{u} gthumb{u} gthumb-data{u}
  gtk2-engines-smooth{u} guile-1.8-libs{u} gvfs-bin{u} hal-cups-utils{u}
  hamster-applet{u} hardinfo{u} kbuild{u} latex-xft-fonts{u}
  libaiksaurus-1.2-0c2a{u} libaiksaurus-1.2-data{u}
  libaiksaurusgtk-1.2-0c2a{u} libart2.0-cil{u} libass3{u}
  libavahi-compat-libdnssd1{u} libberkeleydb-perl{u}
  libboost-python1.39.0{u} libbrasero-media0{u} libbrlapi0.5{u}
  libclass-accessor-perl{u} libclass-singleton-perl{u} libclutter-0.8-0{u}
  libclutter-cairo-0.8-0{u} libclutter-gtk-0.8-0{u} libcolorblind0{u}
  libconfig-tiny-perl{u} libcrypt-passwdmd5-perl{u}
  libcrypt-twofish-perl{u} libcryptui0{u} libdatetime-format-mail-perl{u}
  libdatetime-format-w3cdtf-perl{u} libdatetime-locale-perl{u}
  libdatetime-perl{u} libdatetime-timezone-perl{u} libdmraid1.0.0.rc15{u}
  libdmx1{u} libebackend1.2-0{u} libedata-book1.2-2{u} libedata-cal1.2-6{u}
  libegroupwise1.2-13{u} libepc-1.0-2{u} libepc-common{u}
  libepc-ui-1.0-2{u} libespeak1{u} libestools1.2{u} libevince1{u}
  libexchange-storage1.2-3{u} libexpect-perl{u} libfaad0{u} libffado1{u}
  libfreebob0{u} libfreezethaw-perl{u} libgail-common{u}
  libgail-gnome-module{u} libgalago3{u} libgammu6{u} libgconf2.0-cil{u}
  libgdata-google1.2-1{u} libgdata1.2-1{u} libgdl-1-0{u} libgdl-1-common{u}
  libgdome2-0{u} libgdome2-cpp-smart0c2a{u} libgetopt-argvfile-perl{u}
  libggz2{u} libggzcore9{u} libggzmod4{u} libglade2.0-cil{u}
  libglib2.0-cil{u} libgmime-2.0-2a{u} libgmime-2.4-2{u}
  libgmime2.2a-cil{u} libgmyth0{u} libgmythupnp0{u} libgnome-mag2{u}
  libgnome-pilot2{u} libgnome-speech7{u} libgnome-vfs2.0-cil{u}
  libgnome2-canvas-perl{u} libgnome2-perl{u} libgnome2-vfs-perl{u}
  libgnome2.24-cil{u} libgnomecups1.0-1{u} libgnomepanel2.24-cil{u}
  libgnomeprint2.2-0{u} libgnomeprint2.2-data{u} libgnomeprintui2.2-0{u}
  libgnomeprintui2.2-common{u} libgpgme11{u} libgpod-common{u} libgpod4{u}
  libgsf-gnome-1-114{u} libgsl0ldbl{u} libgsmsd6{u} libgtk2.0-cil{u}
  libgtkglext1{u} libgtkhtml-editor-common{u} libgtkhtml-editor0{u}
  libgtkhtml2-0{u} libgtkhtml3.14-19{u} libgtkmathview0c2a{u}
  libgtksourceview-common{u} libgtksourceview1.0-0{u}
  libgtksourceview2.0-0{u} libgtksourceview2.0-common{u}
  libhtml-strip-perl{u} libio-pty-perl{u} libio-stty-perl{u}
  libkpathsea4{u} liblink-grammar4{u} liblist-moreutils-perl{u}
  libloudmouth1-0{u} liblouis-data{u} liblouis0{u} libmalaga7{u}
  libmissioncontrol-client0{u} libmissioncontrol-server1{u}
  libmldbm-perl{u} libmono-addins-gui0.2-cil{u} libmono-addins0.2-cil{u}
  libmono-cairo2.0-cil{u} libmono-corlib2.0-cil{u}
  libmono-i18n-west2.0-cil{u} libmono-posix2.0-cil{u}
  libmono-security2.0-cil{u} libmono-sharpzip2.84-cil{u}
  libmono-system2.0-cil{u} libmpcdec3{u} libnautilus-burn4{u}
  libndesk-dbus-glib1.0-cil{u} libndesk-dbus1.0-cil{u} libopal3.6.4{u}
  libopenraw1{u} libopenrawgnome1{u} libosp5{u} libots0{u}
  libparams-validate-perl{u} libparted1.8-10{u} libparted1.8-12{u}
  libpisock9{u} libpisync1{u} libpolkit-agent-1-0{u} libpolkit-gtk-1-0{u}
  libpt2.6.4{u} libpt2.6.4-plugins{u} libpth20{u} libqt3-mt{u}
  libsensors-applet-plugin0{u} libsgutils2-2{u} libspectre1{u}
  libspeexdsp1{u} libsub-name-perl{u} libt1-5{u} libtalloc1{u}
  libtelepathy-farsight0{u} libtelepathy2{u} libterm-readkey-perl{u}
  libtotem-plparser12{u} libtrackerclient0{u} libuniversal-require-perl{u}
  libupnp3{u} libuuid-perl{u} libwv-1.2-3{u} libwww-curl-perl{u}
  libx264-68{u} libx264-76{u} libxml++2.6-2{u} libxml-libxml-common-perl{u}
  libxml-libxml-perl{u} libxml-namespacesupport-perl{u}
  libxml-rss-libxml-perl{u} libxml-sax-expat-perl{u} libxml-sax-perl{u}
  liferea{u} liferea-data{u} link-grammar-dictionaries-en{u} mesa-utils{u}
  mono-2.0-gac{u} mono-gac{u} mono-runtime{u} mousetweaks{u} nautilus{u}
  nautilus-cd-burner{u} nautilus-data{u} patchutils{u} perl-tk{u}
  planner{u} policykit-1-gnome{u} python-4suite-doc{u} python-4suite-xml{u}
  python-brlapi{u} python-bugbuddy{u} python-cups{u} python-cupsutils{u}
  python-debian{u} python-eggtrayicon{u} python-evince{u}
  python-evolution{u} python-gdata{u} python-gdbm{u} python-gdl{u}
  python-gksu2{u} python-gnome2-extras{u} python-gnomeprint{u}
  python-gtkglext1{u} python-gtkhtml2{u} python-gtkmozembed{u}
  python-gtksourceview{u} python-gtksourceview2{u} python-gtkspell{u}
  python-gtop{u} python-louis{u} python-mediaprofiles{u} python-metacity{u}
  python-nautilusburn{u} python-opengl{u} python-rsvg{u} python-sexy{u}
  python-uno{u} python-urwid{u} rdesktop{u} samba-common{u}
  samba-common-bin{u} smartmontools{p} smbclient{u} smstools{p}
  sound-juicer{u} swfdec-gnome{u} synaptic{u} system-config-printer{u}
  telepathy-gabble{u} telepathy-mission-control{u} telepathy-salut{u}
  transmission-common{u} transmission-gtk{u} tsclient{u} vino{u}
  w3c-dtd-xhtml{u} wicd{p} wodim{u} xserver-xephyr{u}
  xulrunner-1.9-gnome-support{u}
0 balíkov aktualizovaných, 0 nových nainštalovaných, 295 na odstránenie a 0 neaktualizovaných.
Treba stiahnuť 0B archívov. Po rozbalení sa uvoľní 478MB.
Chcete pokračovať? [Y/n/?]

OS: Debian Testing 64bit, Kernel 2.6.39, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.294
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Re: aptitude purge
« Odpověď #1 kdy: 13. 11. 2009, 21:43:29 »
Jen pro zajímavost, na jakou verzi se ti aktualizoval sysv-rc?
Debian Sid Gnome 64bit
Debian Buster Xfce 64bit


Návod na Netinst instalaci

Offline johnnycage

  • Začátečník
  • **
  • Příspěvků: 90
    • Zobrazit profil
Re: aptitude purge
« Odpověď #2 kdy: 13. 11. 2009, 21:47:01 »
Aktualizoval sa mi na verziu 2.87dsf-8
OS: Debian Testing 64bit, Kernel 2.6.39, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.294
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Re: aptitude purge
« Odpověď #3 kdy: 13. 11. 2009, 21:59:53 »
Zajímavé je, že já mám stejnou verzi (nevím kdy se aktualizoval) a na přechod na nový boot se mě to neptalo. Zkusil jsem zadat
Kód: [Vybrat]
dpkg-reconfigure sysv-rc a nic mi nevyskočilo. Ale boot mi probíhá řekl bych stejným způsobem jako dříve. Tak nevím také kde je chyba.
Debian Sid Gnome 64bit
Debian Buster Xfce 64bit


Návod na Netinst instalaci

Offline Yontalcar

  • Uživatel
  • ***
  • Příspěvků: 131
  • Semper fidelis
    • Zobrazit profil
  • Jabber: yontalcar@jabber.cz
Re: aptitude purge
« Odpověď #4 kdy: 13. 11. 2009, 23:04:53 »
Kód: [Vybrat]
# aptitude keep-alla pak to zkus znovu
NB: ASUS X53U; Debian GNU/Linux Sid amd64 (KDE4)

Jen dvě věci jsou nekonečné - vesmír a lidská hloupost. Tím prvním si ovšem nejsem tak jist. - Albert Einstein

Offline johnnycage

  • Začátečník
  • **
  • Příspěvků: 90
    • Zobrazit profil
Re: aptitude purge
« Odpověď #5 kdy: 14. 11. 2009, 08:32:58 »
Super, dakujem, takto mi to uz funguje. A ked som zadal ten prikaz "aptitude keep-all" nebudu tie ostatne baliky teraz nejako "zamknute", ze by sa s nimi nedalo nic robit (napr. aktualizovat ich)? Resp. netreba ten prikaz nejako vratit naspat?
OS: Debian Testing 64bit, Kernel 2.6.39, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

Offline Yontalcar

  • Uživatel
  • ***
  • Příspěvků: 131
  • Semper fidelis
    • Zobrazit profil
  • Jabber: yontalcar@jabber.cz
Re: aptitude purge
« Odpověď #6 kdy: 14. 11. 2009, 09:08:44 »
z nějakého důvodu byly ty balíky označené k odstranění - pomocí # aptitude keep-all zrušíš všechny naplánované akce (RTFM)
NB: ASUS X53U; Debian GNU/Linux Sid amd64 (KDE4)

Jen dvě věci jsou nekonečné - vesmír a lidská hloupost. Tím prvním si ovšem nejsem tak jist. - Albert Einstein

MartenP

  • Host
Re: aptitude purge
« Odpověď #7 kdy: 14. 11. 2009, 10:31:03 »
Já nevím, ale mě se Squeeze ptal, jestli chci aktivovat závislostní boot, asi před měsícem. Možná je to i déle.

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.294
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Re: aptitude purge
« Odpověď #8 kdy: 14. 11. 2009, 10:36:45 »
No a jak teda poznám, že používám závislostní boot?
Debian Sid Gnome 64bit
Debian Buster Xfce 64bit


Návod na Netinst instalaci

Offline johnnycage

  • Začátečník
  • **
  • Příspěvků: 90
    • Zobrazit profil
Re: aptitude purge
« Odpověď #9 kdy: 14. 11. 2009, 12:16:36 »
Já nevím, ale mě se Squeeze ptal, jestli chci aktivovat závislostní boot, asi před měsícem. Možná je to i déle.

Mna sa tak isto pytal uz asi pred mesiacom, ale vtedy som to len odklikol a nevenoval som pozornost tym logom, ktore sa vypisuju pri upgradovani.
OS: Debian Testing 64bit, Kernel 2.6.39, GNOME 2.30.2
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, WD 320GB, Intel GMA X4500 256MB

MartenP

  • Host
Re: aptitude purge
« Odpověď #10 kdy: 14. 11. 2009, 18:33:48 »
Nevím, jak se to pozná, ale mohu sdělit, že zlepšení/zkrácení bootovací doby je nepotřehnutelné. Mohl bych existovat i bez závislostního bootu. Já jsem raději za zlepšení v oblasti stability než za takové poloužitečné hrátky.

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.294
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Re: aptitude purge
« Odpověď #11 kdy: 14. 11. 2009, 19:02:24 »
no já mám totiž několik PC a mezi bootem Lennyho na jednom PC a Squeeze na druhém PC nevidím vůbec rozdíl.
Debian Sid Gnome 64bit
Debian Buster Xfce 64bit


Návod na Netinst instalaci

MartenP

  • Host
Re: aptitude purge
« Odpověď #12 kdy: 14. 11. 2009, 19:33:11 »
Taktéž nevidím rozdílu. Buď ještě přijde zásadní zlom nebo ten úžasný závislostní boot nepřinesl své ovoce.

Offline Jakub Lucký

  • Uživatel
  • ***
  • Příspěvků: 198
    • Zobrazit profil
    • Skautský oddíl CXL - Praha 4
Re: aptitude purge
« Odpověď #13 kdy: 27. 01. 2010, 22:27:08 »
Ono to zrychlení není (a ani nemůže být) úplně markantní na běžném desktopu a to z několika důvodů

1) za hlavní pomalost může disk... Holt 15k RPM disky se dělají jen do serverů a ty neurychlíte...

2) na běžném desktopu je zcela zjevný závislostní postup, který nejde moc obejít (kernel -> udev -> devicekits, hal, síťovky -> Xorg)... výhodu poznáte pokud vám tam běží 30 služeb, které jsou vzájemně nezávislé a mohou běžet v mnoha threadech...
Developers, developers, developers, developers, developers!