Autor Téma: apt pinning  (Přečteno 12939 krát)

Offline Erich Stark

  • Aktivní­ uživatel
  • ****
  • Příspěvků: 546
    • Zobrazit profil
Re: apt pinning
« Odpověď #15 kdy: 18. 05. 2009, 17:39:17 »
Hmm odstranil som preferences a vyzera to zaujimavo  ::)

Kód: [Vybrat]
debian:/home/erino72# aptitude -t experimental install amarok
Načítavajú sa zoznamy balíkov... Hotovo
Vytvára sa strom závislostí
Načítavajú sa stavové informácie... Hotovo
Načítavajú sa rozšírené stavové informácie
Inicializujú sa stavy balíkov... Hotovo
Načítavajú sa popisy úloh... Hotovo
Nasledujúce balíky sú POŠKODENÉ:
  amarok gconf2 kaudiocreator libc6-dev libc6-i686 libcaca0 libgconf2-4 libqt4-assistant libqt4-core libqt4-designer libqt4-gui libqt4-opengl libqt4-qt3support
  libqt4-sql-mysql libqt4-test locales qt4-qtconfig
Nasledujúce NOVÉ balíky sa nainštalujú:
  exiv2{a} gstreamer0.10-plugins-base{a} gstreamer0.10-plugins-good{a} gstreamer0.10-x{a} gvfs{a} kaboom{a} kde-icons-oxygen{a} kdebase-runtime{a}
  kdebase-runtime-bin-kde4{a} kdebase-runtime-data{a} kdelibs-bin{a} kdelibs5{a} kdelibs5-data{a} libclucene0ldbl{a} libdb4.7{a} libexiv2-5{a} libgpod4-nogtk{a}
  libgssapi-krb5-2{a} libicu40{a} libk5crypto3{a} libkcddb4{a} libkrb5-3{a} libkrb5support0{a} libloudmouth1-0{a} libltdl7{a} libmtp8{a} libphonon4{a} libplasma3{a}
  libqt4-webkit{a} libqtscript4-core{a} libqtscript4-gui{a} libqtscript4-network{a} libqtscript4-sql{a} libqtscript4-uitools{a} libqtscript4-xml{a} libraptor1{a}
  librasqal1{a} libraw1394-11{a} librdf0{a} libshout3{a} libsoprano4{a} libstreamanalyzer0{a} libstreams0{a} libtag-extras0{a} libv4l-0{a} libvolume-id1{a}
  libxml2-utils{a} phonon{a} phonon-backend-gstreamer{a} raptor-utils{a} redland-utils{a}
Nasledujúce balíky sa ODSTRÁNIA:
  amarok-common{u} amarok-engine-xine{a} amarok-konqsidebar{u} kdebase-bin-kde3{a} libcap1{u} libfftw3-3{u} libgpod3-nogtk{u} libifp4{u} libkarma0{u} libmtp7{u}
  libnjb5{u} libofa0{u} libruby1.8{u} libtagc0{u} libtunepimp5{u} ruby{u} ruby1.8{u}
Nasledujúce balíky sa aktualizujú:
  gconf2-common kdemultimedia-kio-plugins libasound2 libc6 libdbus-glib-1-2 libgcrypt11 libglib2.0-0 libgnutls26 libgpg-error0 libgstreamer-plugins-base0.10-0
  libgstreamer0.10-0 libiec61883-0 libpcre3 libpulse0 libqt4-dbus libqt4-network libqt4-script libqt4-sql libqt4-svg libqt4-xml libqtcore4 libqtgui4 libsoup2.4-1
  libsqlite3-0 libtasn1-3 udev
Nasledujúce balíky sú ODPORÚČANÉ, ale NEBUDÚ sa inštalovať:
  libglib2.0-data
29 balíkov aktualizovaných, 51 nových nainštalovaných, 17 na odstránenie a 703 neaktualizovaných.
Treba stiahnuť 137MB archívov. Po rozbalení sa použije 198MB.
Nasledujúce balíky majú nesplnené závislosti:
  libqt4-opengl: Závisí na: libqtcore4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                 Závisí na: libqtgui4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
  libqt4-assistant: Závisí na: libqt4-network (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                    Závisí na: libqtcore4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
  libcaca0: Koliduje s: libcucul0 (< 0.99.beta15) ale 0.99.beta14-1 je nainštalovaný a je ponechaný v aktuálnom stave.
  libqt4-test: Závisí na: libqtcore4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
  libqt4-sql-mysql: Závisí na: libqt4-sql (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                    Závisí na: libqtcore4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
  libqt4-qt3support: Závisí na: libqt4-network (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                     Závisí na: libqt4-sql (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                     Závisí na: libqt4-xml (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                     Závisí na: libqtcore4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                     Závisí na: libqtgui4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
  gconf2: Závisí na: gconf2-common (< 2.23) ale 2.26.0-1 sa bude inštalovať.
  libqt4-core: Závisí na: libqtcore4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
               Závisí na: libqt4-network (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
               Závisí na: libqt4-script (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
               Závisí na: libqt4-xml (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
               Závisí na: libqt4-dbus (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
  libc6-i686: Predzávisí na: libc6 (= 2.7-18) ale 2.9-12 sa bude inštalovať.
  libgconf2-4: Koliduje s: libbonobo2-0 (< 2.24) ale 2.22.0-1 je nainštalovaný a je ponechaný v aktuálnom stave.
  locales: Závisí na: glibc-2.7-1 čo je virtuálny balík.
  libqt4-gui: Závisí na: libqtgui4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
              Závisí na: libqt4-svg (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
  amarok: Závisí na: amarok-common (= 2.0.96-1) ale nedá sa nainštalovať
  libqt4-designer: Závisí na: libqt4-script (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                   Závisí na: libqt4-xml (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                   Závisí na: libqtcore4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                   Závisí na: libqtgui4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
  libc6-dev: Závisí na: libc6 (= 2.7-18) ale 2.9-12 sa bude inštalovať.
  kaudiocreator: Závisí na: kdemultimedia-kio-plugins (= 4:3.5.9-2) ale 4:4.2.2-1 sa bude inštalovať.
  qt4-qtconfig: Závisí na: libqtcore4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
                Závisí na: libqtgui4 (= 4.4.3-1) ale 4.5.1-2 sa bude inštalovať.
otvorené: 8109; uzavreté: 4982; odložené: 0; konfliktné: 118                                                                                                             oPočas prideleného času sa nenašlo žiadne riešenie. Skúsiť dôkladnejšie? [Y/n]
" The box said that I needed to have Windows XP or better ... so I installed Debian ."

Offline Petr

  • Začátečník
  • **
  • Příspěvků: 53
    • Zobrazit profil
    • Kulturistika, posilování
Re: apt pinning
« Odpověď #16 kdy: 18. 05. 2009, 17:50:37 »
Dalo se to čekat, že to nepůjde. Buď nech nebo dej KDE 4.2.2. Je už slušně použitelný. Ohledně pinningu ti neporadím, protože se o to moc nezajímám ;)
Nic není zadarmo a vše souvisí se vším.

Offline Erich Stark

  • Aktivní­ uživatel
  • ****
  • Příspěvků: 546
    • Zobrazit profil
Re: apt pinning
« Odpověď #17 kdy: 18. 05. 2009, 18:31:43 »
Dalo se to čekat, že to nepůjde. Buď nech nebo dej KDE 4.2.2. Je už slušně použitelný. Ohledně pinningu ti neporadím, protože se o to moc nezajímám ;)

Tak je, ale nechapem preco ale nefici mi dobre na mojom noteboku, dovod vidim v grafike, viz podpis
" The box said that I needed to have Windows XP or better ... so I installed Debian ."

Offline Petr

  • Začátečník
  • **
  • Příspěvků: 53
    • Zobrazit profil
    • Kulturistika, posilování
Re: apt pinning
« Odpověď #18 kdy: 18. 05. 2009, 19:22:23 »
Dalo se to čekat, že to nepůjde. Buď nech nebo dej KDE 4.2.2. Je už slušně použitelný. Ohledně pinningu ti neporadím, protože se o to moc nezajímám ;)

Tak je, ale nechapem preco ale nefici mi dobre na mojom noteboku, dovod vidim v grafike, viz podpis

Já mám notebook starý tři roky, horší konfiguraci než ty a šlape jako švýcarský hodinky. Nevím, jestli za to může grafika. Nvidia je docela dobře podporovaná v Linuxu.
Nic není zadarmo a vše souvisí se vším.

Offline nazir

  • Uživatel
  • ***
  • Příspěvků: 141
  • S.N.A.F.U.
    • Zobrazit profil
  • Jabber: nazir@jabber.cz
Re: apt pinning
« Odpověď #19 kdy: 18. 05. 2009, 20:45:52 »
Pokud chceš zkoušet novější verze programů z unstable (sid) a experimental repozitářů, nemá fakt smysl stavět na stable systému.  Stable je tu od toho, aby byl opravdu stabilní (nejen co se týče případných pádů, ale i co se týče verzí programů), na nějaké experimentování IMHO není určený.

Přejdi na testing, u toho nebývají s mixováním výraznější problémy...
Samozřejmě, pokud chceš kamkoliv instalovat něco z experimentalu, tak musíš mít připojené i unstable repozitáře, antož experimental není vydání celého systému, ale pouze "pár" balíčků, které si tahají závislosti právě z unstable, nebo občas i z toho testingu.  Máš unstable v /etc/apt/sources.list?  Možná byly ty problémy právě kvůli tomu...

Pro inspiraci (netvrdím, že to je stoprocentně neprůstřelná konfigurace, nicméně používám ji (v tomto duchu) bez problémů už od doby, co vznikl lenny jako testing):

Kód: ("/etc/apt/apt.conf") [Vybrat]
APT::Cache-Limit 50000000;
APT::Default-Release "testing";
APT::Get::Show-Upgraded "true";
APT::Get::Show-Versions "true";
APT::Install-Recommends "false";
Aptitude::Recommends-Important "false";


Kód: ("/etc/apt/preferences") [Vybrat]
Package: *
Pin: release a=stable
Pin-Priority: -1

Package: *
Pin: release a=lenny
Pin-Priority: -1

Package: *
Pin: release a=testing
Pin-Priority: 600

Package: *
Pin: release a=squeeze
Pin-Priority: 600

Package: *
Pin: release a=unstable
Pin-Priority: 200

Package: *
Pin: release a=sid
Pin-Priority: 200

Package: *
Pin: release a=experimental
Pin-Priority: 1


Kód: ("/etc/apt/sources.list") [Vybrat]
#
##########[etch]################################################################
#deb http://ftp.cz.debian.org/debian/ etch main non-free contrib
#deb-src http://ftp.cz.debian.org/debian/ etch main non-free contrib
#deb http://security.debian.org/ etch/updates main non-free contrib
#deb-src http://security.debian.org/ etch/updates main non-free contrib
################################################################################
#
##########[lenny]###############################################################
#deb http://ftp.cz.debian.org/debian/ lenny main non-free contrib
#deb-src http://ftp.cz.debian.org/debian/ lenny main non-free contrib
#deb http://security.debian.org/ lenny/updates main non-free contrib
#deb-src http://security.debian.org/ lenny/updates main non-free contrib
#deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
#deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
################################################################################
#
##########[squeeze]#############################################################
deb http://ftp.cz.debian.org/debian/ squeeze main non-free contrib
deb-src http://ftp.cz.debian.org/debian/ squeeze main non-free contrib
deb http://security.debian.org/ squeeze/updates main non-free contrib
deb-src http://security.debian.org/ squeeze/updates main non-free contrib
################################################################################
#
##########[sid]#################################################################
deb http://ftp.cz.debian.org/debian/ sid main non-free contrib
deb-src http://ftp.cz.debian.org/debian/ sid main non-free contrib
################################################################################
#
##########[experimental]########################################################
deb http://ftp.cz.debian.org/debian/ experimental main non-free contrib
deb-src http://ftp.cz.debian.org/debian/ experimental main non-free contrib
################################################################################
#
################################################################################
#
##########[Debian Multimedia Packages]##########################################
########## apt-get install debian-multimedia-keyring
#deb http://www.debian-multimedia.org etch main
#deb-src http://www.debian-multimedia.org etch main
#deb http://www.debian-multimedia.org lenny main
#deb-src http://www.debian-multimedia.org lenny main

deb http://www.debian-multimedia.org squeeze main
deb-src http://www.debian-multimedia.org squeeze main

deb http://www.debian-multimedia.org sid main
deb-src http://www.debian-multimedia.org sid main
#deb http://www.debian-multimedia.org experimental main
#deb-src http://www.debian-multimedia.org experimental main
################################################################################
#
#
##########[webmin]##############################################################
########## http://www.webmin.com/jcameron-key.asc
deb http://download.webmin.com/download/repository sarge contrib
################################################################################
#
##########[opera]###############################################################
########## gpg --keyserver subkeys.pgp.net --recv-key 6A423791
########## gpg --fingerprint 6A423791
########## gpg --armor --export  6A423791| apt-key add -
deb http://deb.opera.com/opera lenny non-free
deb http://deb.opera.com/opera sid non-free
################################################################################
#
##########[virtualbox]##########################################################
########## http://download.virtualbox.org/virtualbox/debian/sun_vbox.asc
#deb http://download.virtualbox.org/virtualbox/debian etch non-free
deb http://download.virtualbox.org/virtualbox/debian lenny non-free
################################################################################
#
##########[WineHQ - Debian 4.0 "Etch"]##########################################
#deb http://wine.budgetdedicated.com/apt etch main
#deb-src http://wine.budgetdedicated.com/apt etch main
################################################################################
#
##########[google]##############################################################
########## http://www.google.com/linuxrepositories/
########## http://www.google.com/linuxrepositories/apt.html
##########(https://dl-ssl.google.com/linux/linux_signing_key.pub)###############
#deb http://dl.google.com/linux/deb/ testing non-free
################################################################################
#
##########[Open Metaverse Viewer (The 3D Metaverse for Linux)]##################
########## gpg --keyserver hkp://subkeys.pgp.net --recv-key 0x3b7ee764
########## gpg --export 0x3b7ee764 >robin.gpg
########## su -c "cat robin.gpg | apt-key add -"
# Stable release:
deb http://apt.byteme.org.uk unstable main
deb-src http://apt.byteme.org.uk unstable main
# Release candidate:
deb http://apt.byteme.org.uk experimental main
deb-src http://apt.byteme.org.uk experimental main
################################################################################
« Poslední změna: 18. 05. 2009, 20:46:59 od nazir »

Offline Erich Stark

  • Aktivní­ uživatel
  • ****
  • Příspěvků: 546
    • Zobrazit profil
Re: apt pinning
« Odpověď #20 kdy: 18. 05. 2009, 22:37:52 »
Dalo se to čekat, že to nepůjde. Buď nech nebo dej KDE 4.2.2. Je už slušně použitelný. Ohledně pinningu ti neporadím, protože se o to moc nezajímám ;)

Tak je, ale nechapem preco ale nefici mi dobre na mojom noteboku, dovod vidim v grafike, viz podpis

Já mám notebook starý tři roky, horší konfiguraci než ty a šlape jako švýcarský hodinky. Nevím, jestli za to může grafika. Nvidia je docela dobře podporovaná v Linuxu.

Ja si myslim ze urcite, je to taka onicom..
" The box said that I needed to have Windows XP or better ... so I installed Debian ."

Offline kmarty

  • Začátečník
  • **
  • Příspěvků: 24
    • Zobrazit profil
Re: apt pinning
« Odpověď #21 kdy: 22. 09. 2009, 15:29:32 »
No kurna, ja se z toho pinovani asi zblaznim. Pokazdy kdyz uz si myslim ze do toho trochu vidim, tak se vzdycky vyskytne neco co mne z toho omylu vyvede.
Napriklad nechapu jak se mi muze chtit upgradovat (napr.) libavcodec52 na verzi z "www.debian-multimedia.org", kdyz mam nastaveno:
Kód: [Vybrat]
Package: *
Pin: release o=Muj repozitar
Pin-Priority: 995

Package: *
Pin: release o=Debian,a=testing
Pin-Priority: 991

Package: *
Pin: release o=Unofficial Multimedia Packages,a=testing
Pin-Priority: -1

pritom kdyz preferences doplnim o:
Kód: [Vybrat]
Package: libavcodec52
Pin: release o=Unofficial Multimedia Packages,a=testing
Pin-Priority: -1
Coz by prece melo byt pro ten balik totez co ta hvezdickova verze vyse, tak uz se upgradovat nechce.
Zkratka nechapu. Cucim do tech manualovejch stranek uz par dni jak puk a porad nechapu :-(.

Tyka se to jen Squeeze(o=Debian,a=testing) proti "debian-multimeda"(o=Unofficial Multimedia Packages,a=testing). Baliku 'mplayer' z "Muj repozitar"(o=Muj repozitar,a=moje) se to proti "debian-multimeda" nedotklo (zustala nainstalovana verze z "Muj repozitar").

Nenasla by se dobra duse ktera by mne nakopla spravnym smerem?

Offline kmarty

  • Začátečník
  • **
  • Příspěvků: 24
    • Zobrazit profil
Re: apt pinning
« Odpověď #22 kdy: 29. 09. 2009, 11:03:53 »
Tak "vyreseno"*.

APT::Default-Release v apt.conf vtipne prebiji na pining 990 vse co vyhovi danemu "Suite", bez ohledu na to o co se snazim v preferences. Bohuzel "Unofficial Debian Multimedia Packages" jsou take "testing/squeeze" :-(.
Smazanim APT::Default-Release je to "vyresene".


*) V uvozovkach proto, ze si nejsem uplne jisty ze jde o spravne reseni. Nicmene v tuto chvili to dela to co chci.

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.261
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Re: apt pinning
« Odpověď #23 kdy: 08. 05. 2010, 09:05:58 »
Rád bych oživil toto téma. Chtěl bych začít konečně používat apt pinning, ale nemůžu se v tom nějak zorientovat. Můj případ je následující. Mám nainstalovyný Debian Sid + nějaké balíky z Experimental. Systém bych chtěl nastavit tak, aby výchozí byl Sid s tím, že pár balíků bych chtěl aktualizovat z Experimentalu. Například Iceweasel nebo třeba Chromium. Problém je v tom, že jsem četl jak manuál, tak spoustu konfiguráků, ale každej používá jiný číslo pro pin priority. Proto by mě to zajímalo na tomto konkrétním příkladě.
Debian Gnome 64bit

Návod na Netinst instalaci

Offline Yontalcar

  • Uživatel
  • ***
  • Příspěvků: 131
  • Semper fidelis
    • Zobrazit profil
  • Jabber: yontalcar@jabber.cz
Re: apt pinning
« Odpověď #24 kdy: 08. 05. 2010, 10:28:49 »
Rád bych oživil toto téma. Chtěl bych začít konečně používat apt pinning, ale nemůžu se v tom nějak zorientovat. Můj případ je následující. Mám nainstalovyný Debian Sid + nějaké balíky z Experimental. Systém bych chtěl nastavit tak, aby výchozí byl Sid s tím, že pár balíků bych chtěl aktualizovat z Experimentalu. Například Iceweasel nebo třeba Chromium. Problém je v tom, že jsem četl jak manuál, tak spoustu konfiguráků, ale každej používá jiný číslo pro pin priority. Proto by mě to zajímalo na tomto konkrétním příkladě.
Kód: (/etc/apt/preferences) [Vybrat]
Package: *
Pin: release a=unstable
Pin-Priority: 980

Package: *
Pin: release a=experimental
Pin-Priority: 200

Package: iceweasel
Pin: version *
Pin-Priority: 980

Package: iceweasel-l10n-cs
Pin: version *
Pin-Priority: 980
NB: ASUS X53U; Debian GNU/Linux Sid amd64 (KDE4)

Jen dvě věci jsou nekonečné - vesmír a lidská hloupost. Tím prvním si ovšem nejsem tak jist. - Albert Einstein

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.261
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Re: apt pinning
« Odpověď #25 kdy: 08. 05. 2010, 10:38:47 »
Jsem asi natvrdlej, ale když chci mít například Iceweasel z Experimental, nemělo by to vypadat spíš takhle:

Kód: [Vybrat]
Package: *
Pin: release a=unstable
Pin-Priority: 980

Package: *
Pin: release a=experimental
Pin-Priority: 200

Package: iceweasel
Pin: version *
Pin-Priority: 200

Package: iceweasel-l10n-cs
Pin: version *
Pin-Priority: 200

Pokud ne, prosím o vysvětlení a také by mě zajímalo, zda se bude Iceweasel automaticky aktualizovat, když do Experimental přijde novější verze. A pak mě také zajímá proč pin priority 980 a 200. Potom už mi to snad bude jasnější.. :D
« Poslední změna: 08. 05. 2010, 10:47:49 od Ota Trkola »
Debian Gnome 64bit

Návod na Netinst instalaci

Offline Yontalcar

  • Uživatel
  • ***
  • Příspěvků: 131
  • Semper fidelis
    • Zobrazit profil
  • Jabber: yontalcar@jabber.cz
Re: apt pinning
« Odpověď #26 kdy: 08. 05. 2010, 13:18:07 »
about Pin-Priority:
Citace: man apt_preferences;přeloženo
500 < P <=990
    způsobí, že verze bude instalována, pokud není dostupná verze patřící k cílovému vydání nebo pokud je instalovaná verze novější

100 < P <=500
    způsobí, že verze bude instalována, pokud není dostupná verze patřící k nějaké jiné distribuci nebo pokud je instalovaná verze novější
--> "standardní" hodnoty jsou mezi 500 a 900 (tudíž já mám 890), experimental standardně nechci, takže 200

tím, že mám u iceweaslu version *, v podstatě zrovnoprávním všechny verze (na Pin-Priority 980), takže bude instalována ta, která má nejvyšší verzi

iceweasel si ti pak samozřejmě bude aktualizovat automaticky
« Poslední změna: 08. 05. 2010, 13:19:24 od Yontalcar »
NB: ASUS X53U; Debian GNU/Linux Sid amd64 (KDE4)

Jen dvě věci jsou nekonečné - vesmír a lidská hloupost. Tím prvním si ovšem nejsem tak jist. - Albert Einstein

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.261
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Re: apt pinning
« Odpověď #27 kdy: 08. 05. 2010, 13:57:14 »
Takže pokud tam mám tohle, tak je to ok?

Kód: [Vybrat]
Package: *
Pin: release a=unstable
Pin-Priority: 980

Package: *
Pin: release a=experimental
Pin-Priority: 200

Package: iceweasel
Pin: version *
Pin-Priority: 980

Package: iceweasel-l10n-cs
Pin: version *
Pin-Priority: 980

Package: libmozjs3d
Pin: version *
Pin-Priority: 980

Package: xulrunner-*
Pin: version *
Pin-Priority: 980
Debian Gnome 64bit

Návod na Netinst instalaci

Offline Yontalcar

  • Uživatel
  • ***
  • Příspěvků: 131
  • Semper fidelis
    • Zobrazit profil
  • Jabber: yontalcar@jabber.cz
Re: apt pinning
« Odpověď #28 kdy: 08. 05. 2010, 15:11:35 »
Takže pokud tam mám tohle, tak je to ok?

Kód: [Vybrat]
Package: *
Pin: release a=unstable
Pin-Priority: 980

Package: *
Pin: release a=experimental
Pin-Priority: 200

Package: iceweasel
Pin: version *
Pin-Priority: 980

Package: iceweasel-l10n-cs
Pin: version *
Pin-Priority: 980

Package: libmozjs3d
Pin: version *
Pin-Priority: 980

Package: xulrunner-*
Pin: version *
Pin-Priority: 980
Není - žolíkové znaky obecně nefungují --> nemůžeš napsat "xulrunner-*"
NB: ASUS X53U; Debian GNU/Linux Sid amd64 (KDE4)

Jen dvě věci jsou nekonečné - vesmír a lidská hloupost. Tím prvním si ovšem nejsem tak jist. - Albert Einstein

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.261
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Re: apt pinning
« Odpověď #29 kdy: 08. 05. 2010, 15:23:45 »
OK, takže takto:

Kód: [Vybrat]
Package: *
Pin: release a=unstable
Pin-Priority: 980

Package: *
Pin: release a=experimental
Pin-Priority: 200

Package: iceweasel
Pin: version *
Pin-Priority: 980

Package: iceweasel-l10n-cs
Pin: version *
Pin-Priority: 980

Package: libmozjs3d
Pin: version *
Pin-Priority: 980

Package: xulrunner-1.9.2
Pin: version *
Pin-Priority: 980

Package: chromium-browser
Pin: version *
Pin-Priority: 980

Package: chromium-browser-inspector
Pin: version *
Pin-Priority: 980

Package: chromium-browser-l10n
Pin: version *
Pin-Priority: 980
« Poslední změna: 08. 05. 2010, 17:44:22 od Ota Trkola »
Debian Gnome 64bit

Návod na Netinst instalaci