Autor Téma: i3wm - Otevírání aplikací vyžadujících sudo  (Přečteno 1096 krát)

Offline JoHo

  • Začátečník
  • **
  • Příspěvků: 44
    • Zobrazit profil
Re:i3wm - Otevírání aplikací vyžadujících sudo
« Odpověď #15 kdy: 20. 12. 2019, 06:46:06 »
Děkuji za odpověď.
Prosím o posouzení mé instalace "nudně stabilního" sida, což bylo pro mě  dobrodružství. Zatím dobře že jen na Virtuál.

1. V holém listému lxde jsem změnil v sources.list první 2 řádky z huster na sid, ostatní jsem buď zakomentoval nebo vymazal.
2. Přidal jsem stejné 2 řádky jako testing, vytvořil soubor /etc/apt/preferences s nastavením 1000 : 100 ve prospěch sid.
3. Nainstaloval apt-listbugs a apt-listchanges.
4. Výsledkem byl nefunkční systém. Nemohl jsem ani upgradovat, ani instalovat, protože apt-listbug mně ukazoval vždy nějaké chybové balíčky, a tak jsem instalaci zarazil.

Potom jsem objevil video a postupoval podle něho.
1. Plná instalace Debian buster lxde (dotyčný má gnome).
2. Upravil jsem v sources.list první 2 řádky na sid, ostatní nechal.Takto:
Kód: [Vybrat]


# deb cdrom:[Debian GNU/Linux 10.2.0 _Buster_ - Official amd64 NETINST 20191116-09:56]/ buster main

#deb cdrom:[Debian GNU/Linux 10.2.0 _Buster_ - Official amd64 NETINST 20191116-09:56]/ buster main

deb http://deb.debian.org/debian/ sid main contrib non-free
deb-src http://deb.debian.org/debian/ sid main contrib non-free

deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
a s tímto nastavením to funguje. Instalace i updates.
Mám znovu nainstalované i apt-listbugs a apt-listchanges. Zatím vše šlape.
Při mé nezkušenosti bych potřeboval poradit, co udělat jinak nebo co doplnit. Přidat případně znovu testing a nastavit preference?
Otázku bych potom rád ukončil. Děkuji za každou radu.

Offline Roman Horník

  • Hlavní moderátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.357
    • Zobrazit profil
  • Jabber: roman.hornik@jabber.cz
Re:i3wm - Otevírání aplikací vyžadujících sudo
« Odpověď #16 kdy: 20. 12. 2019, 22:21:05 »
V prvním případě jsi musel někde udělat chybu, mohl stačit jenom překlep. listbugs ani listchanges nepoužívám, minoritní nebo žádný zásahy do kódu mě nezajímaj, seznam změn si můžu zobrazit v Synapticu, když potřebuju, když vyjde majoritnější sada změn, informace typu "New upstream version" mě zdržujou.
Jestli používáš především Synaptic, nepotřebuješ měnit priority, v jeho nastavení si jen zvolíš upřednostňovaný vydání. Stačí jen v sources.list jeden řádek pro jedno vydání a druhej pro druhý. Jinak se použije u apt/apt-get/aptitude nejnovější verze, tedy z vyššího vydání, jinak můžeš použít APT pinning pro konkrétní balík.
Debian Sid 64bit + Mate Desktop Environment
* CPU: Intel i5 3570
* GPU: NVIDIA GTX650 1GD5
* MB: Lenovo IH61M
* RAM: 16GiB Deutsche Demokratische Republik 3

Offline JoHo

  • Začátečník
  • **
  • Příspěvků: 44
    • Zobrazit profil
Re:i3wm - Otevírání aplikací vyžadujících sudo
« Odpověď #17 kdy: 21. 12. 2019, 08:27:05 »
Děkuji za tvoji dosavadní pomoc.
Dnešní odpověď ve které ničemu nerozumím mě však definitivně přesvědčila, že debian unstable zatm opravdu není pro mně. Potřeboval jsem jen vědět, co je v mém sources.list špatné nebo nadbytečné.
Prošel jsem dost stránek na googlu, kde mně listbugs i listchanges velmi (zvláště jako začátečníkovi) doporučují.
Citace
https://linuxconfig.org/how-to-run-debian-sid-relatively-safely
Protože se však nerad vzdávám, budu pokračovat v hledání.

Offline Roman Horník

  • Hlavní moderátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.357
    • Zobrazit profil
  • Jabber: roman.hornik@jabber.cz
Re:i3wm - Otevírání aplikací vyžadujících sudo
« Odpověď #18 kdy: 22. 12. 2019, 12:59:04 »
Ono to není o unstable (Sidovi), kterej se od starších vydání liší tím, že má novější software (Debian není Ubuntu, aby potřeboval padat), ale o míchání vydání. To se hodí jen tehdy, kdy potřebuješ starší verzi programu (např. Blender - držím si verzi 2.79, protože verze 2.80 má změněný GUI na infantilně laděný a míň přehledný, některý projekty, animovaný, v něm nejdou otevřít), nebo když používáš program, jenž byl z novějšího vydání odstraněn (například proto, že se dlouho neudržuje). Jinak to nepotřebuješ.
Mícháním vydání a používáním starších balíků s kvantem závislostí se dále vystavuješ riziku, že budeš muset udržovat starší verze knihoven v závislostech, na kterejch jsou závislý další nainstalovaný programy, který taky budeš muset držet ve starším provedení.
Znovu - když k tomu nemáš jó důvod, nepotřebuješ míchat vydání.
Debian Sid 64bit + Mate Desktop Environment
* CPU: Intel i5 3570
* GPU: NVIDIA GTX650 1GD5
* MB: Lenovo IH61M
* RAM: 16GiB Deutsche Demokratische Republik 3

Offline JoHo

  • Začátečník
  • **
  • Příspěvků: 44
    • Zobrazit profil
Re:i3wm - Otevírání aplikací vyžadujících sudo
« Odpověď #19 kdy: 22. 12. 2019, 18:18:15 »
Moc děkuji. Hodně jsem toho za poslední dny prošel.

1. Rorumím tvé odpovědi správně? Potom tedy stačí v sources.list pouze
Kód: [Vybrat]
deb http://deb.debian.org/debian/ sid main contrib non-free
deb-src http://deb.debian.org/debian/ sid main contrib non-free
a ne např. tento sources.list
Kód: [Vybrat]
deb http:/deb.debian.org/debian/ sid main contrib non-free
deb-src http://deb.debian.org/debian/ sid main contrib non-free

deb http://deb.debian.org/debian/ testing main contrib non-free
deb-src http:/deb.debian.org/debian/ testing main contrib non-free

deb http://deb.debian.org/debian/ stable main contrib non-free
deb-src http:/deb.debian.org/debian/ stable main contrib non-free

deb http://security.debian.org stable/updates main contrib non-free
deb http://security.debian.org testing/updates main contrib non-free

deb http://www.debian-multimedia.org/ stable main
deb http://www.debian-multimedia.org/ testing main
deb http://www.debian-multimedia.org/ unstable main
deb http://deb.debian.org/debian/ oldstable main contrib non-free
a k tomu soubor se stanovením preferencí a a vložení GPG klíče pro www.debian-multimedia.org?
Ota Trkola např na své stránce doporučuje
Kód: [Vybrat]
deb http://ftp.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.debian.org/debian/ sid main contrib non-free
deb http://www.debian-multimedia.org/ sid main
deb http://ftp.debian.org/debian/ experimental main contrib non-free
deb-src http://ftp.debian.org/debian/ experimental main non-free contrib
nebo další doporučení
Kód: [Vybrat]
deb http://ftp.us.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.us.debian.org/debian/ sid main
 
deb http://ftp.us.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.us.debian.org/debian/ testing main
Prošel jsem toho tolik, že bez pomoci nevím jak dál.

2. Když nenainstaluju apt-listbugs apt-listchanges, jak píšeš že nepoužíváš, znamená to, že mně nevyjedou chyby, které si před updatem nebo instalací aplikace pečlivě prohlížím v chybovém hlášení. Bez toho se bojím pokračovat. Moc děkuji za dosavadní pomoc.


Offline Roman Horník

  • Hlavní moderátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.357
    • Zobrazit profil
  • Jabber: roman.hornik@jabber.cz
Re:i3wm - Otevírání aplikací vyžadujících sudo
« Odpověď #20 kdy: 22. 12. 2019, 18:33:06 »
Z prvního Ti stačí jen první řádek (nebo líp z českýho zrcadla: deb http://ftp.cz.debian.org/debian/ sid main non-free contrib), jestliže nechceš stahovat a kompilovat zdrojáky (deb-src). Experimental do toho nemíchej, tam už jsou balíky kvalitní jak v Ubuntu (a mimo to bys musel řešit rozkopaný závislosti - na to jseš ještě "mladej").
S deb-multimedia není problém, klíč se dá po přidání pohodlně nainstalovat pomocí # apt install deb-multimedia-keyring, nebo ten samej balík najdeš v Synapticu.
« Poslední změna: 22. 12. 2019, 18:57:04 od Roman Horník »
Debian Sid 64bit + Mate Desktop Environment
* CPU: Intel i5 3570
* GPU: NVIDIA GTX650 1GD5
* MB: Lenovo IH61M
* RAM: 16GiB Deutsche Demokratische Republik 3

Offline JoHo

  • Začátečník
  • **
  • Příspěvků: 44
    • Zobrazit profil
Re:i3wm - Otevírání aplikací vyžadujících sudo
« Odpověď #21 kdy: 22. 12. 2019, 21:12:57 »
Ano,
tak se to blíží už k závěru. Můj sources list tedy bude
 
Kód: [Vybrat]
deb http://ftp.cz.debian.org/debian/ sid main non-free contrib
deb http://www.debian-multimedia.org/ sid main
Ještě bych prosil odpověď na 2. bod
2. Když nenainstaluju apt-listbugs apt-listchanges, jak píšeš že nepoužíváš, znamená to, že mně nevyjedou chyby, které si před updatem nebo instalací aplikace pečlivě prohlížím v chybovém hlášení. Bez toho se bojím při mých zkušenostech pokračovat. Děkuji.


Offline Roman Horník

  • Hlavní moderátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.357
    • Zobrazit profil
  • Jabber: roman.hornik@jabber.cz
Re:i3wm - Otevírání aplikací vyžadujících sudo
« Odpověď #22 kdy: 23. 12. 2019, 04:34:17 »
Ne, nevyjedou.
Debian Sid 64bit + Mate Desktop Environment
* CPU: Intel i5 3570
* GPU: NVIDIA GTX650 1GD5
* MB: Lenovo IH61M
* RAM: 16GiB Deutsche Demokratische Republik 3