Dotazy > Hardware

failed to set xfermode (err_mask=0x40)

(1/3) > >>

Milano:
Zdravim.
Vyměnil jsem  v notebooku thinkpad t400 HDD za SSD  ADATA SP580.  Při boot dostávám hlášku " ata1.00: failed to set xfermode (err_mask=0x40) ".
Firmware SSD je nejnovější a nic moc jsem nevygooglil. Nevíte někdo co s tím?
Díky.


--- Kód: ---root@thinkpad:/home/milan# dmesg | grep ata1
[    2.450795] ata1: SATA max UDMA/133 abar m2048@0xfc226000 port 0xfc226100 irq 29
[    2.791362] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    2.796848] ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
[    2.796852] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[    2.796854] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[    7.904048] ata1.00: qc timeout (cmd 0x47)
[    7.904056] ata1.00: READ LOG DMA EXT failed, trying unqueued
[    7.904059] ata1.00: failed to get Log Directory Emask 0x40
[    7.904061] ata1.00: ATA-10: ADATA SP580, 1.0.0.5, max UDMA/133
[    7.904063] ata1.00: 234441648 sectors, multi 1: LBA48 NCQ (depth 31/32), AA
[    7.904065] ata1.00: failed to get Identify Device Data, Emask 0x40
[    7.904073] ata1.00: failed to set xfermode (err_mask=0x40)
[    8.219595] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    8.225082] ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
[    8.225085] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[    8.225088] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[    8.235138] ata1.00: NCQ Send/Recv Log not supported
[    8.246040] ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
[    8.246043] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[    8.246045] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[    8.256093] ata1.00: NCQ Send/Recv Log not supported
[    8.256276] ata1.00: configured for UDMA/133

--- Konec kódu ---

Roman Horník:
To znamená, že se boot nedokončí? Nebo je to jen nežádoucí chybová hláška?
Nicméně jsem našel, že do parametru zavádění jádra by mohlo stačit přidat irqpoll, tzn. do /etc/default/grub, do řádku GRUB_CMDLINE_LINUX - pak by mělo stačit spustit # update-grub a restartovat.

Nebo to bude bug v jádru, v tomhle případě bych zkusil jinou jeho verzi, ideálně novější.

aricak:
Ahoj já jsem vygooglil toto:
https://bbs.archlinux.org/viewtopic.php?id=107847 Možná pomůže nevím.

Roman Horník:
No jo, jenže to je bug 7 let starýho jádra. Může to bejt jistě něco podobnýho, ale určitě ne stejnýho. Já bych teda zkusil novější jádro, například v Experimentalu už je 4.14-rc5.

Milano:

--- Citace: Roman Horník  23. 10. 2017, 03:39:50 ---To znamená, že se boot nedokončí? Nebo je to jen nežádoucí chybová hláška?
Nicméně jsem našel, že do parametru zavádění jádra by mohlo stačit přidat irqpoll, tzn. do /etc/default/grub, do řádku GRUB_CMDLINE_LINUX - pak by mělo stačit spustit # update-grub a restartovat.

Nebo to bude bug v jádru, v tomhle případě bych zkusil jinou jeho verzi, ideálně novější.

--- Konce citace ---

Boot normálně proběhne. Jenom se mi zdá, že je něco špatně, protože windows bootuje asi tak 3x rychleji. Irqpoll  jsem zkusil a nic se nezměnilo. Jádro ještě vyzkouším.

Navigace

[0] Seznam témat

[#] Další strana

Přejít na plnou verzi