Autor Téma: letsencrypt-auto - Segmentation fault  (Přečteno 2212 krát)

Offline vaclavambroz

  • Nováček
  • *
  • Příspěvků: 5
    • Zobrazit profil
    • Blog Václava Ambrože
  • Jabber: vaclavambroz@vaclavambroz.cz
letsencrypt-auto - Segmentation fault
« kdy: 03. 01. 2016, 05:58:40 »
Ahoj všem,

používám Debian unstable a dříve mi šlo bez problému vystavovat certifikáty pomocí letsencrypt-auto, nicméně teď mi to vždy skončí na Segmentation fault. Skript skončí u  /root/.local/share/letsencrypt/bin/pip install -U setuptools:

Kód: [Vybrat]
+ XDG_DATA_HOME=/root/.local/share
+ VENV_NAME=letsencrypt
+ VENV_PATH=/root/.local/share/letsencrypt
+ VENV_BIN=/root/.local/share/letsencrypt/bin
+ dirname ./letsencrypt-auto
+ LEA_PATH=.
+ BOOTSTRAP=./bootstrap
+ id -u
+ test 0 -ne 0
+ SUDO=
+ [ ! -d /root/.local/share/letsencrypt ]
+ DeterminePythonVersion
+ command -v python2.7
+ export LE_PYTHON=python2.7
+ sed s/\.//
+ cut -d. -f1,2
+ cut -d  -f 2
+ python2.7 --version
+ PYVER=27
+ [ 27 -eq 26 ]
+ [ 27 -lt 26 ]
+ printf Updating letsencrypt and virtual environment dependencies...
Updating letsencrypt and virtual environment dependencies...+ [  = 1 ]
+ /root/.local/share/letsencrypt/bin/pip install -U setuptools
Segmentation fault

Máte někdo podobnou zkušenost? Máte představu jak to vyřešit? Díky.

Offline vaclavambroz

  • Nováček
  • *
  • Příspěvků: 5
    • Zobrazit profil
    • Blog Václava Ambrože
  • Jabber: vaclavambroz@vaclavambroz.cz
Re:letsencrypt-auto - Segmentation fault
« Odpověď #1 kdy: 16. 01. 2016, 12:00:05 »
Problém se mi povedlo vyřešit. Jednalo se v podstatě o špatné cesty u příkazu pip. Řešení problému jsem popsal na https://blog.vaclavambroz.cz/debian-letsencrypt-a-segmentation-fault/.