Autor Téma: problem gcc  (Přečteno 1230 krát)

Offline tribalcz

  • Začátečník
  • **
  • Příspěvků: 101
    • Zobrazit profil
problem gcc
« kdy: 03. 02. 2014, 22:04:21 »
Zdravim kvůli instala nvidia driveru jsem se dostal do docela svízelné situace a to takové že potřebuji gcc 4.6 ale já mám gcc 4.7 jistě už víte kam tím mířím nicméně opatřil jsem si si verzi 4.6.2 odtud ftp://mirror.oss.maxcdn.com/gnu/gcc/ a podle navodu ze stranky http://gcc.gnu.org/wiki/InstallingGCC jsem chtel provest kompilaci ale zasekl jsem se

celý návod zní

Kód: [Vybrat]
tar xzf gcc-4.6.2.tar.gz
cd gcc-4.6.2
./contrib/download_prerequisites
cd ..
mkdir objdir
cd objdir
$PWD/../gcc-4.6.2/configure --prefix=$HOME/gcc-4.6.2
make
make install

z toho mi nejde vykonat tento příkaz

Kód: [Vybrat]
$PWD/../gcc-4.6.2/configure --prefix=$HOME/gcc-4.6.2
vždy skončím s touto odpovědí

Kód: [Vybrat]
OME/gcc-4.6.2
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln works... yes
checking whether ln -s works... yes
checking for a sed that does not truncate output... /bin/sed
checking for gawk... no
checking for mawk... mawk
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/home/martin/Stažené/objdir':
configure: error: no acceptable C compiler found in $PATH

v repo jsem našel gcc 4.6 nejspise 4.6.4 ale tu nedokáže systém zavést

Offline Matesax

  • Začátečník
  • **
  • Příspěvků: 49
  • Dlouholetý programátor se znalostmi a zkušenostmi
    • Zobrazit profil
Re:problem gcc
« Odpověď #1 kdy: 04. 02. 2014, 06:05:40 »
Dostávají mě lidi jako jsi ty:
"configure: error: in `/home/martin/Stažené/objdir':
configure: error: no acceptable C compiler found in $PATH"

Co ti na to mám napsat - aby si zase na mě nikdo nestěžoval? To nemůžeš prostě změnit hodnotu proměnné $PATH v kompilovaném souboru? Nebo co jako po nás chceš? Od čeho jsou errory? Aby jste tu s nimi spamovali, anebo vykonali to, co vám errory říkají? To je rovnou můžeme zrušit...
Nevěřím v nic - pak má víra jest vyšší, než kterákoliv jiná...

Offline Petr Gajdůšek

  • Začátečník
  • **
  • Příspěvků: 60
    • Zobrazit profil
Re:problem gcc
« Odpověď #2 kdy: 06. 02. 2014, 00:26:57 »
Kód: [Vybrat]
configure: error: no acceptable C compiler found in $PATH

Potřebuješ C překladač (třeba gcc  ;))

Citace
v repo jsem našel gcc 4.6 nejspise 4.6.4 ale tu nedokáže systém zavést

Co znamená "tu nedokáže systém zavést" ? GCC 4.6. by ti měl jít normálně nainstalovat z repozitáře. To nejde? Z repozitáře můžeš mít zároveň nainstalováno i více verzí, gcc-4.7 klidně ponechat, není důvod ho odstraňovat.

K instalaci nvidia driveru nepotřebuješ nic ručně kompilovat. Proč nenainstaluješ nvidia-kernel-dkms balík (nebo jeden z legacy pokud máš starou kartu) z repozitáře, o kompilaci se ti automaticky postará DKMS. Potřebuješ k tomu již jen nainstanstalovat balík s hlavičkovými soubory pro své jádro.
Návod (velice jednoduchý) je na https://wiki.debian.org/NvidiaGraphicsDrivers. Potřebuješ s ním poradit, nebo ti nefunguje?