Autor Téma: nvidia geforce7150m  (Přečteno 2448 krát)

Offline martasek

  • Začátečník
  • **
  • Příspěvků: 58
    • Zobrazit profil
nvidia geforce7150m
« kdy: 20. 04. 2013, 11:39:23 »
ahoj,

  mám debian 7.0, jádro 3.2.0-4-686-pae, prostředí KDE 4.x  a grafickou kartu nvidia geforce 7150m. podle návodu zde na tomto webu nelze tuto grafickou kratu zprovoznit. mohl by mi někdo poradit jak na to? přestala fungovat o aktualizace na nové jádro, module assistant nepomohl. v současné době je nová instalace systému a výsledek je stejný.

valsin

  • Host
Re: nvidia geforce7150m
« Odpověď #1 kdy: 20. 04. 2013, 12:13:11 »
Akú verziu ovládačov si nainštaloval. Skúšal si aj nouveau driver ? Ja som na tom behal s mojou nvidia v pohode aj hry som hrával urban terror a podobne, výkon tam bol celkom slušný.

Offline Roman Horník

  • Hlavní moderátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.326
    • Zobrazit profil
  • Jabber: roman.hornik@jabber.cz
Re: nvidia geforce7150m
« Odpověď #2 kdy: 20. 04. 2013, 12:30:41 »
Jak nejde? Upřesni, třeba jde, ale vidíš jen černou obrazovku, nebo nejde, a vypíše to nějakou chybu, kterou bych tady rád viděl.
Debian Sid 64bit + Mate Desktop Environment
* CPU: Intel Pentium G2020
* GPU: NVIDIA GTX650 1GD5
* MB: LenINovo IH61M
* RAM: 8GiB Deutsche Demokratische Republik 3

Offline martasek

  • Začátečník
  • **
  • Příspěvků: 58
    • Zobrazit profil
Re: nvidia geforce7150m
« Odpověď #3 kdy: 20. 04. 2013, 13:01:45 »
jak nejde? nevím. při spuštění počítače systém najede pouze do příkazové řádky bez pokusu o naběhnutí KDE. při pokusu instalace pomocí module assistant vypíše "balík nvidia-kernel-source nebyl sestaven korektně, podrobnosti naleznete v ..........."

a v těch podrobnostech se nevyznám, ale mě přijde, že žádná chyba.

Offline bronix

  • Nováček
  • *
  • Příspěvků: 12
    • Zobrazit profil
Re: nvidia geforce7150m
« Odpověď #4 kdy: 20. 04. 2013, 17:37:53 »
Skús nainštalovať Nouveau slobodný ovládač a potom reštartuj PC.
Kód: [Vybrat]
sudo aptitude install xserver-xorg-video-nouveau

Offline Roman Horník

  • Hlavní moderátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.326
    • Zobrazit profil
  • Jabber: roman.hornik@jabber.cz
Re: nvidia geforce7150m
« Odpověď #5 kdy: 21. 04. 2013, 02:56:24 »
Takže pohádka o blackscreenu:
Příběh začíná v době nedávný, kdy došlo k jistým změnám někde kolem libc6, a zároveň se nVidia rozhodla ukončit podporu karet GF 6xxx a 7xxx. Důsledkem těchto činů staly se ovladače karet těchto řad zcela nefunkčními, při nejlepším pouze s nefunkčním rozšířením GLX.
Bohužel, nVidia na tyto změny snad dosud nikterak nezareagovala, vždyť taky proč, když už vyrábí stokrát výkonnější, ješ ještě spoustu let bude podporovat?
Aby mohl uživatel i nadále karty těchto řad používat, buďto si musí nainstalovat Squeezeho, nebo downgradovat pár oněch libc6 balíků, což lze relativně bezproblémově realizovat u Wheezyho, u Sida to může bejt větší problém, protože už teď má dost aplikací novějších, vyžadujících určitý verze inkriminovaných balíků.
Nouveau bych v případě KDE moc nedoporučil, je o dost slabší, je možný, že prostředí, který systémovejma prostředkama zrovna dvakrát nešetří (vlastně je to takovej Otesánek), prostě tahle karta ne moc dobře utáhne.
Proto zkus tohle: http://forum.debian-linux.cz/index.php/topic,1174.0.html
Konec pohádky, která je natolik reálná, až to hezký není.
Debian Sid 64bit + Mate Desktop Environment
* CPU: Intel Pentium G2020
* GPU: NVIDIA GTX650 1GD5
* MB: LenINovo IH61M
* RAM: 8GiB Deutsche Demokratische Republik 3

Offline Palo M.

  • Uživatel
  • ***
  • Příspěvků: 140
    • Zobrazit profil
Re: nvidia geforce7150m
« Odpověď #6 kdy: 21. 04. 2013, 09:27:22 »
Pokial viem, tak k nvidiackym ovladacom je niekolko legacy verzii. Tie by mali fungovat na starsie karty.
Aktualna verzia nvidia-glx je 304.88, ale mali by byt k dispozicii aj 173.14.35, aj 96.43.23 a dokonca aj 71.86.15... kazda verzia ma samozrejme v zavislostiach aj svoju vlastnu verziu DKMS kernel-modulu aj Xorg ovladaca...
http://packages.debian.org/search?suite=wheezy&section=all&arch=any&searchon=names&keywords=nvidia-glx-legacy
V Squeeze je nvidia-glx vo verzii 195.36.31. Takze ak karta chodila v Squeeze s balikom nvidia-glx, vo Wheezym by som vyskusal najprv nvidia-glx-legacy-173xx. Je celkom sanca ze tam bude pre tu kartu podpora.

Offline Roman Horník

  • Hlavní moderátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.326
    • Zobrazit profil
  • Jabber: roman.hornik@jabber.cz
Re: nvidia geforce7150m
« Odpověď #7 kdy: 21. 04. 2013, 11:17:09 »
Ne, nejde to ani se staršíma ovladačema.
Debian Sid 64bit + Mate Desktop Environment
* CPU: Intel Pentium G2020
* GPU: NVIDIA GTX650 1GD5
* MB: LenINovo IH61M
* RAM: 8GiB Deutsche Demokratische Republik 3

Offline Palo M.

  • Uživatel
  • ***
  • Příspěvků: 140
    • Zobrazit profil
Re: nvidia geforce7150m
« Odpověď #8 kdy: 22. 04. 2013, 10:04:44 »
No to je neprijemne, ale predpokladam ze Nvidia "len" vyhodila podporu starsich kariet len v aktualnej verzii ovladacov, ale snad "nepokazila" tie legacy baliky v Debiane...
Pravdepodobne sa teda udiali nejake zmeny v jadre a libc, ktore sposobili, ze tie (starsie) ovladace sa momentalne nedaju skompilovat (a v aktualnych ovladacoch zas nie je podpora starsich kariet).
Tak snad ludia, co robia patricne baliky, by mali zabezpecit funkcnost balikov...
Ale nevidim to medzi RC-bugmi (uz len 13!), tak sa mi nezda, ze by to vobec nechodilo. Mozno to len nikto nereportoval, ale IMHO je toto dost zavazna chyba (nedavno bola podobna chyba, ze pre virtualbox DKMS moduly kompilacia zlyhala a to v RC-bugoch bolo a rychlo to aj bolo vyriesene...). Tak neviem, ci tuto chybu nikto nereportoval...