Autor Téma: Wifi - připojí se ale nejede...  (Přečteno 3579 krát)

Offline Pana_Ruplahlava

  • Nováček
  • *
  • Příspěvků: 2
    • Zobrazit profil
Wifi - připojí se ale nejede...
« kdy: 27. 03. 2012, 17:30:19 »
Ahoj, přelezl jsem z ubuntu na debian, vše krásně a líp šlape, ale...
pokusil jsem se doinstalovat wifi podle návodu http://wiki.debian.org/WiFi, všechno se nainstalovalo, sítě mi to najde, můžu se připojit, ale následně mi internet nejede...
v tomhle nemám vůbec zkuešnosti, neví někdo?

Offline Pana_Ruplahlava

  • Nováček
  • *
  • Příspěvků: 2
    • Zobrazit profil
Re:Wifi - připojí se ale nejede...
« Odpověď #1 kdy: 27. 03. 2012, 17:40:54 »
tak edit, někdy to jede někdy ne, záleží na tom jak se pc vyspí :D (podle toho jak to restartuju)

Offline mouseman

  • Nováček
  • *
  • Příspěvků: 2
    • Zobrazit profil
Re:Wifi - připojí se ale nejede...
« Odpověď #2 kdy: 01. 12. 2013, 21:00:44 »
Zdravím, mám uplně stejný problém.
Debian Jessie/sid, iwlwifi nainstalován, wifi karta: Intel Centrino N 1030, router Asus RT-AC66U.
Mám dual boot a na win 7 wifi jede OK. Prosím o postrčení co dál. Na Ubuntu 13.10 stejný problém. Jednou wifi chvíli jede a pak už nic.

Offline Matesax

  • Začátečník
  • **
  • Příspěvků: 49
  • Dlouholetý programátor se znalostmi a zkušenostmi
    • Zobrazit profil
Re:Wifi - připojí se ale nejede...
« Odpověď #3 kdy: 22. 12. 2013, 10:16:50 »
dmesg | tail je asi nejkouzelnější věcička. U WiFi se totiž bude dost pravděpodobně jednat o vyhledávání správné frekvence atd. přes CRDA. Ubuntu mi neustále vyhazuje spojení a nesmyslně znovu vyhledává, co již dávno našel... A co vím, tak se toho moc vyřešit nedá. Zaprvé pomáhá vyndat a zandat adaptér - potažmo modprobe. No a také jsem viděl pokusy přehazovat interface. Vzpomínám i na problémy s U:Fon adaptérem - ono je tohle dost těžké udělat pro svobodný OS...
Nevěřím v nic - pak má víra jest vyšší, než kterákoliv jiná...

Offline mouseman

  • Nováček
  • *
  • Příspěvků: 2
    • Zobrazit profil
Re:Wifi - připojí se ale nejede...
« Odpověď #4 kdy: 22. 12. 2013, 21:49:09 »
Po připojení wifi na jiný router TENDA A5 vše jede OK. Tak je problém na ASUSu............

Offline Matesax

  • Začátečník
  • **
  • Příspěvků: 49
  • Dlouholetý programátor se znalostmi a zkušenostmi
    • Zobrazit profil
Re:Wifi - připojí se ale nejede...
« Odpověď #5 kdy: 22. 12. 2013, 22:26:50 »
Měl jsi na tamtom routeru nastavenou IP napevno? Pokud ne, tak je to jak jsem psal - znovu a znovu se vyhledávají správné parametry...
Nevěřím v nic - pak má víra jest vyšší, než kterákoliv jiná...

Offline sabraq

  • Začátečník
  • **
  • Příspěvků: 31
    • Zobrazit profil
Re:Wifi - připojí se ale nejede...
« Odpověď #6 kdy: 25. 12. 2013, 16:50:47 »
Po připojení wifi na jiný router TENDA A5 vše jede OK. Tak je problém na ASUSu............
A za čím ten router máš? Neměl bys mít dva routery za sebou (2x NAT), co se týče té Tendy/Asusu, ve výchozím stavu z továrny mohou mít nastavený jiný kanál, to může mít v zarušeném prostředí vliv (výchozí kanál v Tendě je pro tebe vhodnější, než byl ten v Asusu), nebo-li měl jsi zkusit kanálovat ten Asus.Za další je výhodné sjednotit si standardy (b,g,n)... Vím, že moje návrhy nevysvětlují, proč ti to funguje ve Win7 a v Debianu ne, výměna routeru však také ne.

Offline ondra

  • Nováček
  • *
  • Příspěvků: 1
    • Zobrazit profil
Re:Wifi - připojí se ale nejede...
« Odpověď #7 kdy: 26. 12. 2013, 19:19:38 »
Ahoj všem,
jsem začínajícím uživatelem Debianu (a Linuxu vůbec) a mám podobný problém. Nainstaloval jsem si (NetInstall) verzi Debianu 7.3 a na začátku instalace jsem zvolil alternativní desktop Xfce (instaluju na slabý netbook). Instalace proběhla v pořádku, data z internetu byla přes Wifi stažena OK, ale po druhém restartu přestal internet fungovat. NetworkManager se přihlásí k wifi, ale internet nefunguje.  Vzácně začne fungovat, ale nepodařilo se mi vysledovat nějakou závislost či sekvenci kroků, která by to způsobila.
Mohl by mi někdo poradit jak zjistit více podrobností? Nějaké logy? Jak se přiblížit ke zdroji problému?

Offline sabraq

  • Začátečník
  • **
  • Příspěvků: 31
    • Zobrazit profil
Re:Wifi - připojí se ale nejede...
« Odpověď #8 kdy: 29. 12. 2013, 21:50:06 »
Ahoj všem,
jsem začínajícím uživatelem Debianu (a Linuxu vůbec) a mám podobný problém. Nainstaloval jsem si (NetInstall) verzi Debianu 7.3 a na začátku instalace jsem zvolil alternativní desktop Xfce (instaluju na slabý netbook). Instalace proběhla v pořádku, data z internetu byla přes Wifi stažena OK, ale po druhém restartu přestal internet fungovat. NetworkManager se přihlásí k wifi, ale internet nefunguje.  Vzácně začne fungovat, ale nepodařilo se mi vysledovat nějakou závislost či sekvenci kroků, která by to způsobila.
Mohl by mi někdo poradit jak zjistit více podrobností? Nějaké logy? Jak se přiblížit ke zdroji problému?
Zkus zjistit jakou tam máš síťovku:

Kód: [Vybrat]
lspci -vvZajímá tě sekce bezdrátové karty, na jejím konci bude i použitý modul, tedy ovladač.

Zde je popsán podobný problém:

https://forum.debian-linux.cz/index.php?topic=1479.0

Případně dmesg ti něco může prozradit

Kód: [Vybrat]
dmesg | grep wlan