Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Příspěvky - Enigma

Stran: [1] 2
1
Hardware / AverMedia TD310
« kdy: 18. 05. 2016, 08:04:38 »
Musel jsem si pořídit novou TV kartu, protože ta stará Averka si přestala rozumět se systémem (verze stretch). Volba padla na AverMedia TD310, která podporuje též DVB-T2, HEVC. Ať nemusím hned tak inovovat, když se bude DVB-T vypínat.
Na Win 10 64bit TD310 jede, ale nedaří se to rozběhat na Linuxu, a zrovna Aver patří k těm méně problematickým. Bohužel mi není jasné z dmesg či lsusb, co je třeba provézt. Starší Averka potřebovala jenom doplnit fw soubor, který tam ještě je.

Zde je část výpisu z dmesg
Kód: [Vybrat]
[    0.948749] usb 1-13: New USB device found, idVendor=07ca, idProduct=1871
[    0.948756] usb 1-13: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    0.948760] usb 1-13: Product: TD310 Device
[    0.948764] usb 1-13: Manufacturer: AVerMedia
[    0.948767] usb 1-13: SerialNumber: 308397700015

Dále tu máme lsusb -v
Kód: [Vybrat]
Bus 001 Device 002: ID 07ca:1871 AVerMedia Technologies, Inc.
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0x07ca AVerMedia Technologies, Inc.
  idProduct          0x1871
  bcdDevice            1.00
  iManufacturer           1
  iProduct                2
  iSerial                 3
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           46
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           4
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      0
      bInterfaceProtocol      0
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x84  EP 4 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x85  EP 5 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0

Hláška Couldn't open device, some information will be missing se mi ukazuje i u jiných zařízení, která ale fungují.

2
Archiv ČT, TV Nova nebo YouTube normálně jdou. Jenže Prima Play ne, místo spouštění videa se ukáže hláška
Citace
Video nemohlo být načteno, buď kvůli chybě serveru nebo sítě nebo proto, že daný formát není podporován.
a nazdar bazar.
Prozatím řeším restartem do Windows, tam to funguje.
Běží to na nějakém exotickém kodeku nebo jsou diskriminováni uživatelé se starší verzí Flashe?

3
Dragon a VLC jdou již spustit po instalaci nového ovladače nVidia grafiky, ovšem ze stránek nVidia, ne z repozirářů. Mohli bychom napsat vyřešeno, ale ještě bych byl opatrný.

4
Dávám na vědomí, že od poslední aktualizace nefunguje dragonplayer a vlc. Na příkazovém řádku dostanu následující.
Dragon:
Kód: [Vybrat]
Neoprávněný přístup do paměti (SIGSEGV)VLC:
Kód: [Vybrat]
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
Neoprávněný přístup do paměti (SIGSEGV)

5
Mám tento TV tuner. Vím o něm tolik, že to má elektroniku Siano Mobile a že ve Windows šlape normálně. Potřebné firmware soubory jsem si totiž z Windows oddílu zkopíroval. Příslušný kernel modul "smsdvb" jsem natáhl. Jenže když dám ladit, stroj zcela vytuhne a pomůže jen reset tlačítkem na almaře. Zajímavé je, že na Raspberry Pi se systémem Raspbian (upraveným Debianem pro Malinu) se mi podařilo stanice naladit, bohužel ale Raspberry nemá výkon na sledování TV.

6
Mám tu další zajímavou informaci ze světa Raspberry Pi. Zadařilo se do nového kernelu, konkrétně v distribuci Raspbian Wheezy implementovat dynamické přetaktování s možností až 1 GHz, což umožňuje zvednout výkon až o 50%. Proti přehřátí to ošetřené je, pokud teplota dosáhne 85 st.C, RasPi plyn ubere. Záruka na přístroj není ohrožena.
Před používáním bude třeba provézt update již nainstalovaného systému. Jak jinak než pomocí
Kód: [Vybrat]
sudo apt-get update && sudo apt-get upgradeJde to i přes klikátka, ale někdy je to rychlejší přes terminál.
Po té je třeba spustit jakožto root raspi-config, dát ho updatovat, v novější verzi pak je možnost nastavení přetaktování. Pod volbou Configure overclocking se otevře nabídka možností přetaktování, která vypadá takto:
Kód: [Vybrat]
None    700MHz ARM, 250MHz core, 400MHz SDRAM, 0 overvolt
Modest  800MHz ARM, 300MHz core, 400MHz SDRAM, 0 overvolt
Medium  900MHz ARM, 333MHz core, 450MHz SDRAM, 2 overvolt
High    950MHz ARM, 450MHz core, 450MHz SDRAM, 6 overvolt
Turbo   1000MHz ARM, 500MHz core, 500MHz SDRAM, 6 overvolt
Pokud nebude chtít systém nastartovat s nejvyšší volbou, je třeba startovat s podržením shift (pro safemode) a zkusit nižší hodnotu. Záleží na tom, na jaký kousek jste narazili či nakolik dobrý je napájecí zdroj.

Více informací:
http://www.raspi.cz/2012/09/zvyste-vykon-raspberry-pi-az-50/
http://www.raspberrypi.org/archives/2008

Další zajímavou informací je, kterou jsem se dozvěděl zase na slovenské stránce raspi.sk je, že existuje projekt předpřipravené emulace RasPi ve QEMU pro Windows, více o tom na http://raspi.sk/raspberry-pi-emultor-pre-windows/ .

7
Jistě se k vám též doneslo pár informací o tomto ARMovém minipočítači, který vyvolal tak obrovský zájem, že je na pořadník a odběr omezen na 1 ks/os. Nijak zvlášť závratný výkon se od toho čekat nedá, ale mělo by to postačit na přehrávání HD videa, kancelář, internet či na emulaci slavných počítačů 80. let 20. století. Operačním systémem této mašinky je zamýšleno několik distribucí Linuxu, nás tady bude zajímat Debian. Dále je k dispozici pro RasPi Fedora, AROS, Raspian (upravený Debian), OpenELEC (HTPC distro) apod.
Budou se prodávat dva modely, nižší jakožto A za 25 USD a vyšší jakožto B za 35 USD. Ceny nejsou konečné, není v nich započítána DPH, doprava a samozřejmě nutné příslušenství.

Parametry sestavy:
CPU 700MHz ARM11
256MB SDRAM
OpenGL ES 2.0
1080p30 H.264 high-profile decode
Composite / HDMI výstup
1x USB 2.0
SD/MMC/SDIO paměťový slot
Vyšší model navíc obsahuje další USB 2.0 port a LAN port

Více informací je na těchto stránkách:
Česky: http://www.raspi.cz a http://www.pi-raspberry.cz
Anglicky: http://www.raspberrypi.org a http://elinux.org/RaspberryPiBoard
Obchody: http://cz.rs-online.com/web/generalDisplay.html?id=raspberrypi ; http://www.element14.com/community/groups/raspberry-pi a http://www.alliedelec.com/RaspberryPi/

Dost se na tento stroječek těším. Dobře by mi posloužil jako HTPC k CRT televizoru na chatě. Jak byste ho použili vy?

Aktualizace: Od dnešního dne již pořadníky a omezení 1 ks na osobu padá. Možno již přímo objednávat Raspberry Pi u RS Components a Premier Farnell, v jakémkoliv množství. Informace je zajímavá pro ty, kteří chtějí provozovat více strojů RasPi současně (např. zařídit počítačovou učebnu). Je tu ovšem jedno ale. Dodací doba je v řádech týdnů, zřejmě dáno tím, že je třeba ještě uspokojit lidi z pořadníků.

Aktualizace 2: Už mi to dorazilo, RS Components vyexpedovalo moji zásilku do DHL v pátek. Zásilka došla v pořádku, zatím jsem to nezkoušel, musel jsem při vší smůle dělat na něčem jiném.
 Vyzkouším určitě Raspbian, Raspbmc a z jiného soudku RISC OS. Možná bude i něco víc.

Aktualizace 3: Tak už jsem to začal zkoušet, rozjel jsem na tom Raspbmc, RISC OS a zkusím ještě ten Raspbian.
Raspbmc vypadá, že by mohlo celkem jít, uvidím, jak bude šlapat na starší televizi na chatě. Akorát že doma u televizoru s USB vstupy to nemá význam. Raspbmc přetaktovává procesor z původních 700 na 800 MHz. Vypadá to, že to bezpečné je, ale kdoví, jestli tam radši ten chladič nenalepím. Zbyly mi nějaké ty chladiče na grafické paměti.
Zkusil jsem již také RISC OS, je to zatím v alfa stádiu, má to své mouchy, ale rýsuje se z toho svižný systém.
Poslední, co hodlám zkusit bude Raspbian, jedná se o Debian vyladěný pro RasPi.
Určitě sem napíšu později, co jsem ještě vyzkoušel.

8
Hardware / Re:CUPS 1.5.2 vs. HP 5L
« kdy: 26. 04. 2012, 16:29:23 »
Čím to jenom bylo, se už nedozvíme.
Prováděl jsem přehrnutí systému a tiskárna už zase jde.
Neboli ono to vyřešeno je i není.

9
Jelikož ovladač od nVidie na tuhle starou grafiku není v nabídce repozitářů, stáhl jsem si tedy instalačku ze stránek nVidie.
Instalace jako taková proběhla. Udělal jsem jakýs takýs xorg.conf dle instrukcí, ale nefungovalo to.
Dávám sem errorlog:
Kód: [Vybrat]
[   241.653]
X.Org X Server 1.11.4
Release Date: 2012-01-27
[   241.654] X Protocol Version 11, Revision 0
[   241.654] Build Operating System: Linux 2.6.32-5-amd64 i686 Debian
[   241.654] Current Operating System: Linux debian 3.2.0-2-686-pae #1 SMP Tue Mar 20 19:48:26 UTC 2012 i686
[   241.654] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-2-686-pae root=UUID=5be9a020-7e11-40fc-b5af-b1fc6f2ac06e ro quiet
[   241.654] Build Date: 05 March 2012  04:16:09AM
[   241.654] xorg-server 2:1.11.4-1 (Cyril Brulebois <kibi@debian.org>)
[   241.654] Current version of pixman: 0.24.4
[   241.655] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[   241.655] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   241.656] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr  5 19:00:42 2012
[   241.656] (==) Using config file: "/etc/X11/xorg.conf"
[   241.656] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   241.657] (==) No Layout section.  Using the first Screen section.
[   241.657] (**) |-->Screen "Default Screen" (0)
[   241.657] (**) |   |-->Monitor "Configured Monitor"
[   241.657] (==) No device specified for screen "Default Screen".
Using the first device section listed.
[   241.657] (**) |   |-->Device "Configured Video Device"
[   241.657] (==) Automatically adding devices
[   241.657] (==) Automatically enabling devices
[   241.658] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   241.658] Entry deleted from font path.
[   241.658] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[   241.658] Entry deleted from font path.
[   241.658] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[   241.658] (==) ModulePath set to "/usr/lib/xorg/modules"
[   241.658] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[   241.658] (II) Loader magic: 0xb77a6580
[   241.658] (II) Module ABI versions:
[   241.658] X.Org ANSI C Emulation: 0.4
[   241.658] X.Org Video Driver: 11.0
[   241.658] X.Org XInput driver : 13.0
[   241.658] X.Org Server Extension : 6.0
[   241.659] (--) PCI: (0:0:10:0) 14f1:8800:0070:9800 rev 5, Mem @ 0xcc000000/16777216
[   241.659] (--) PCI:*(0:1:0:0) 10de:002d:10de:0001 rev 21, Mem @ 0xc8000000/16777216, 0xc4000000/33554432, BIOS @ 0x????????/65536
[   241.663] (II) Open ACPI successful (/var/run/acpid.socket)
[   241.663] (II) "extmod" will be loaded by default.
[   241.663] (II) "dbe" will be loaded by default.
[   241.663] (II) "glx" will be loaded by default.
[   241.663] (II) "record" will be loaded by default.
[   241.663] (II) "dri" will be loaded by default.
[   241.663] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[   241.663] (II) LoadModule: "dri2"
[   241.664] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   241.665] (II) Module dri2: vendor="X.Org Foundation"
[   241.665] compiled for 1.11.4, module version = 1.2.0
[   241.665] ABI class: X.Org Server Extension, version 6.0
[   241.665] (II) Loading extension DRI2
[   241.665] (II) LoadModule: "extmod"
[   241.665] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   241.666] (II) Module extmod: vendor="X.Org Foundation"
[   241.666] compiled for 1.11.4, module version = 1.0.0
[   241.666] Module class: X.Org Server Extension
[   241.666] ABI class: X.Org Server Extension, version 6.0
[   241.666] (II) Loading extension SELinux
[   241.666] (II) Loading extension MIT-SCREEN-SAVER
[   241.666] (II) Loading extension XFree86-VidModeExtension
[   241.666] (II) Loading extension XFree86-DGA
[   241.666] (II) Loading extension DPMS
[   241.666] (II) Loading extension XVideo
[   241.666] (II) Loading extension XVideo-MotionCompensation
[   241.666] (II) Loading extension X-Resource
[   241.666] (II) LoadModule: "dbe"
[   241.667] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   241.667] (II) Module dbe: vendor="X.Org Foundation"
[   241.667] compiled for 1.11.4, module version = 1.0.0
[   241.667] Module class: X.Org Server Extension
[   241.667] ABI class: X.Org Server Extension, version 6.0
[   241.667] (II) Loading extension DOUBLE-BUFFER
[   241.667] (II) LoadModule: "glx"
[   241.667] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   241.699] (EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so: /usr/lib/xorg/modules/extensions/libglx.so: undefined symbol: LookupIDByType
[   241.699] (II) UnloadModule: "glx"
[   241.699] (II) Unloading glx
[   241.699] (EE) Failed to load module "glx" (loader failed, 7)
[   241.699] (II) LoadModule: "record"
[   241.700] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   241.700] (II) Module record: vendor="X.Org Foundation"
[   241.700] compiled for 1.11.4, module version = 1.13.0
[   241.700] Module class: X.Org Server Extension
[   241.700] ABI class: X.Org Server Extension, version 6.0
[   241.700] (II) Loading extension RECORD
[   241.700] (II) LoadModule: "dri"
[   241.701] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   241.701] (II) Module dri: vendor="X.Org Foundation"
[   241.701] compiled for 1.11.4, module version = 1.0.0
[   241.701] ABI class: X.Org Server Extension, version 6.0
[   241.701] (II) Loading extension XFree86-DRI
[   241.701] (II) LoadModule: "nvidia"
[   241.701] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   241.704] (EE) Failed to load /usr/lib/xorg/modules/drivers/nvidia_drv.so: /usr/lib/xorg/modules/drivers/nvidia_drv.so: undefined symbol: miTranslateRegion
[   241.705] (II) UnloadModule: "nvidia"
[   241.705] (II) Unloading nvidia
[   241.705] (EE) Failed to load module "nvidia" (loader failed, 7)
[   241.705] (EE) No drivers available.
[   241.705]
Fatal server error:
[   241.705] no screens found
[   241.705]
Please consult the The X.Org Foundation support
at http://wiki.x.org
 for help.
[   241.706] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   241.706] 

Co vlastně chce glx a nvidia modul?
Kód: [Vybrat]
[   241.699] (EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so: /usr/lib/xorg/modules/extensions/libglx.so: undefined symbol: LookupIDByType
[   241.704] (EE) Failed to load /usr/lib/xorg/modules/drivers/nvidia_drv.so: /usr/lib/xorg/modules/drivers/nvidia_drv.so: undefined symbol: miTranslateRegion

Dodatek: Problém nevyřešen. Nouveau zatím dobře neposlouží. Proveden návrat zpět k onboard grafice SiS Mirage. Zkusím grafiku osadit později, pokud bude Nouveau na tom lépe.

10
Hardware / Re:Nouveau
« kdy: 04. 04. 2012, 22:58:10 »
Také se i já připojuji s problémem s Nouveau ovladačem, konkrétně mrznutí systému. Systém je Debian Wheezy (testing), karta nVidia TNT2. Jak to tady mám rozjet? Lze nějak kloudně Nouveau nahradit?
Starší nv nebo nvidia-legacy z unstable jsem zkoušel nainstalovat, ale bezúzpěšně.
Nechápu proč není v testing ještě přístupno nv, když je Nouveau takový polotovar.

11
Hardware / Re:CUPS 1.5.2 vs. HP 5L
« kdy: 21. 03. 2012, 19:09:27 »
Když jsem dal něco vytisknout, v error_log se nic neprojevilo.

Jedině, když systém nastartuje, jsou tam tyto zprávy:
Citace
E [21/Mar/2012:19:03:20 +0100] Avahi client failed, closing client to allow a clean restart
W [21/Mar/2012:19:04:20 +0100] failed to CreateProfile: org.freedesktop.DBus.Error.NoReply:Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

12
Hardware / CUPS 1.5.2 vs. HP 5L
« kdy: 16. 03. 2012, 12:53:21 »
Doposud, co na Linuxu tisknu, neměl jsem žádný závažný problém s tiskem, dokonce HP 5L fungovala lépe než ve Win XP. Bohužel od té doby, co CUPS povýšil na 1.5.2, nejsem schopen nic vytisknout na tiskárně HP 5L.
Jak se to projevuje: Napřed svítí prostřední zelená ledka, dolní zelená bliká, místo rozběhnutí dojde k tomu, že ty dvě zelené svítí stále a nic se neděje.
Myslím si, že v CUPS bude nejspíš bug v obsluze LPT portu.

13
Vypadá to, že to v tomhle bylo, na laptopu Kaffeine opět funguje.

Opraveno a funguje už i na desktopu.
Někdy i linuxový program dokáže překvapit, ale když se ví, jak to opravit, je to hned.

14
Do prvního příspěvku doplněny informace o počítači a systému.
I na mém laptopu je stejný problém. Je to Fujitsu-Siemens AMILO Pro V2060, zvuková karta Intel AD198x, též Debian Testing.
Jelikož se jedná o běžné on-board zvukovky, které by měly normálně jít. Vypadá to na chybu softwarovou, buď v balíku Kaffeine, nebo v nějakém jeho doprovodném. Vypadá to tedy na to, že problém bude vyřešen, až výjde oprava.

15
Zřejmě mi poslední aktualizace na Debianu Testing způsobila, že mi přestalo fungovat Kaffeine, jak by mělo. Ať chci něco v něm přehrát či pustit si TV kartu, vyskočí na mě hláška "Zvukové zařízení není k dispozici". Zkoušel jsem smazat konfiguráky, načisto program přeinstalovat, nic z toho nepomohlo. Je ještě něco, co mám zkusit? Zvukovou kartu používám tu, co je na desce ASRock K7S41GX, zřejmě AD1888. Na jiných programech funguje. Na ovladač zvukovky bych to neviděl.
Kaffeine používám nejvíce na televizní kartu.
Pro tentokrát jsem to vyřešil instalací Me-TV, ale radši bych měl zpět Kaffeine provozuschopné. Příjde mi, že umí skoro vše, co Windowsí obslužný program TV karty.

Stran: [1] 2