Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Témata - Ota Trkola

Stran: 1 2 3 [4] 5
46
Nepoužíváte někdo script, který se spustí startu PC a funguje tak, že se provede update, upgrade a clean. Potřebuju to pro uživatele, kteří netuší co to jsou aktualizace. Chtěl bych to tak, aby se to uživatele pokud možno na nic neptalo, protože tomu stejně nerozumí a nevěděl by co s tím. Prostě, aby aktualizace proběhla na pozadí. Předem vylučuju možnost použití update manager a update notifier. Takže pokud někdo něco máte, nebo byste to uměli naprogramovat, byl bych vcelku rád.

47
Všeobecná podpora / Kopírování DVD na ISO
« kdy: 18. 04. 2010, 17:14:33 »
Zdravím, analfabet potřebuje poradit. Po delší době jsem chtěl kopírovat film na DVD do ISO souboru na disk. Jako jsem byl zvyklý, tak jsem klikl pravým na ikonu DVD a chtěl jsem ho kopírovat, Bohužel tato volba je neaktivní. Nevíte někdo, co mi chybí, aby to fungovalo?


48
Na Sidovi mi přestal fungovat radeonhd, proto jsem musel přejít na Squeeze, pokud by někdo věděl co stím, byl bych moc rád. Moje karta je HD2600XT 512MB.

49
V poslední době jsem řešil problémy s DNS servery mého poskytovatele. Problémy byly s nenačítáním některých stránek, některé se sice načetly, ale nenačetly se celé. Jindy jsem čekal třeba 5 vteřin než se stránka začne načítät. Nakonec jsem problém vyřešil použitím Google Public DNS a vytvořením lokální DNS cache. V návodu je počítáno s použitím textového editoru gedit, pokud používáte jiné prostředí než Gnome, použijte jiný editor.

Stránka Google Public DNS:

http://code.google.com/intl/cs/speed/public-dns/

1. Nainstalujeme balík dnsmasq:

Kód: [Vybrat]
$ sudo aptitude install dnsmasq
2. Nastavíme nové DNS editací souboru /etc/resolv.conf:

Kód: [Vybrat]
$ gksudo gedit /etc/resolv.conf
obsah souboru musí vypadat takto:

Kód: [Vybrat]
nameserver 127.0.0.1
nameserver 8.8.8.8
nameserver 8.8.4.4

Tím máme nastavené nové DNS.

3. Vytvoříme lokální DNS cache:

Otevřeme soubor /etc/dhcp/dhclient.conf

Kód: [Vybrat]
$ gksudo gedit /etc/dhcp/dhclient.conf
Odkomentujeme (smažeme křížek) tento řádek:

Kód: [Vybrat]
#prepend domain-name-servers 127.0.0.1;
Takže bude vypadat takto:

Kód: [Vybrat]
prepend domain-name-servers 127.0.0.1;
Uložíme a zavřeme.

Otevřeme soubor /etc/dnsmasq.conf

Kód: [Vybrat]
$ gksudo gedit /etc/dnsmasq.conf
Najdeme tento řádek:

Kód: [Vybrat]
#listen-addres=
Odkomentujeme ho a upravíme takto:

Kód: [Vybrat]
listen-addres=127.0.0.1
Uložíme a zavřeme.

4.V Terminálu provedeme restart dnsmasq

Kód: [Vybrat]
$ sudo /etc/init.d/dnsmasq restart
Hotovo. Po tomto mi běží net jak z praku a nemám problémy s načtením jakékoliv stránky, nečekám na její dlouhé načítání a pokaždé se okamžitě načte celá. Doufám, že tenhle návod někomu pomůže.

50
Správa a instalace softwaru / Java v prohlížeči nefunguje
« kdy: 05. 03. 2010, 22:07:29 »
Všiml jsem si že mi na Squeeze nejede java v prohlížeči. Nevěděli byste někdo proč?

Kód: [Vybrat]
Java Plug-in 1.6.0_16
Using JRE version 1.6.0_16-b01 Java HotSpot(TM) Server VM
User home directory = /home/otas
----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------


load: class JavaVersionDisplayApplet.class not found.
java.lang.ClassNotFoundException: JavaVersionDisplayApplet.class
at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:152)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:445)
at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:2880)
at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1397)
at java.lang.Thread.run(Thread.java:619)
Caused by: java.net.ConnectException: Network is unreachable
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:525)
at sun.net.NetworkClient.doConnect(NetworkClient.java:161)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)
at sun.net.www.http.HttpClient.<init>(HttpClient.java:233)
at sun.net.www.http.HttpClient.New(HttpClient.java:306)
at sun.net.www.http.HttpClient.New(HttpClient.java:323)
at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:860)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:801)
at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:726)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1049)
at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:373)
at sun.plugin2.applet.Applet2ClassLoader.getBytes(Applet2ClassLoader.java:458)
at sun.plugin2.applet.Applet2ClassLoader.access$000(Applet2ClassLoader.java:46)
at sun.plugin2.applet.Applet2ClassLoader$1.run(Applet2ClassLoader.java:126)
at java.security.AccessController.doPrivileged(Native Method)
at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:123)
... 6 more
Exception: java.lang.ClassNotFoundException: JavaVersionDisplayApplet.class

51
Představuji návod na instalaci Debianu Buster (stable) pomocí Netinst ISO obrazu. Netinst ISO obraz obsahuje pouze instalátor a balíčky, které jsou potřeba k instalaci základního systému. Velikost tohoto instalačního média se pohybuje kolem 250MB. Výhodou použití tohoto instalačního obrazu je možnost instalace libovolného grafického prostředí.



UPOZORNĚNÍ:
Před instalací systému zálohujte veškerá důležitá data!



1. Pro začátečníky

Debian Buster (stable) - stabilní vydání Debianu vydané v červenci 2019, obsahující starší software, ale systém je odladěný, bez závažných chyb.

Znaky použité před příkazy mají následující význam:

$ - příkaz provádíme jako obyčejný uživatel. Je vhodné, aby uživatel byl ve skupině sudo, viz bod 5

# - příkaz musí být proveden jako root. To znamená, že musí být použit Terminál uživatele root v grafickém prostředí nebo musí být přihlášen uživatel root (v textovém prostředí):

Kód: [Vybrat]
su root
2. Co potřebujeme k instalaci

Netinst ISO obraz Debianu Buster

Funkční připojení k internetu ve chvíli, kdy instalujeme

3. Odkazy pro stažení Netinst ISO obrazů

Debian Buster 64bit

4. Instalace

Stažený obraz vypálíme na CD nebo uložíme na USB flash disk a nabootujeme.

Pokud chceme uložit obraz na USB flash disk, postupujeme následujícím způsobem:

Připojíme do USB portu prázný USB flash disk a spustíme následující příkaz ze složky, ve které máme instalační obraz uložený:

Kód: [Vybrat]
$ dd if=*.iso of=/dev/sdX
"*" je přesný název staženého obrazu. "X" je označení USB flash disku, který chcete použít.

Spustíme instalaci a projdeme intuitivním procesem instalace.

V průběhu instalace si vybereme grafické desktopové prostředí pomocí mezerníku, v našem případě Gnome.

Po dokončení instalace a restartu se dostaneme do grafického prostředí nově nainstalovaného operačního systému, kde se přihlásíme svým uživatelským jménem a heslem, které jsme si zvolili v průběhu instalace.

5. Přidání uživatele do skupiny sudo

Zadáme postupně následující příkazy:

Kód: [Vybrat]
$ su root
zadáme heslo uzivatele root

Kód: [Vybrat]
# apt install sudo
# adduser "uzivatel" sudo
# reboot

"uzivatel" zaměňíme za své uživatelské jméno.

Po restartu se opět přihlásíme svým uživatelským jménem a heslem.

6. Úprava zdrojů software

Kód: [Vybrat]
$ sudo nano /etc/apt/sources.list
Kód: [Vybrat]
deb http://ftp.debian.org/debian/ buster main contrib non-free
deb-src http://ftp.debian.org/debian/ buster main contrib non-free
deb http://security.debian.org/ buster/updates main contrib non-free
deb-src http://security.debian.org/ buster/updates main contrib non-free
deb http://www.deb-multimedia.org/ buster main non-free

Kód: [Vybrat]
$ sudo apt update
$ sudo apt upgrade

7. Instalace firmware

Otevřeme terminál a zadáme:

Kód: [Vybrat]
$ sudo apt install firmware-linux-free firmware-linux-nonfree
V případě, že počítač je vybaven wifi modulem, nainstalujeme také firmware pro správný chod tohoto hardware. Například pro karty Broadcom:

Kód: [Vybrat]
$ sudo apt install firmware-brcm80211
Vhodný firmware lze vyhledat například na stránkách Debian Wikipedia

Hotovo. Nyní zbývá jen doladit vzhled, doinstalovat další aplikace, které používáte a užívat si systému, tak jak jsme si ho vytvořili.

52
Ahoj asi 2-3 dny mám na jednom PC problém při aptitude (apt-get) update. Začnou se aktualizovat seznamy balíků:

Kód: [Vybrat]
otas-desktop:/home/otas# aptitude update
Mám:1 http://dl.google.com testing Release.gpg [189B]
Cíl http://ftp.debian.org squeeze Release.gpg                                  
Cíl http://ftp.debian.org squeeze/main Translation-cs                          
Ign http://ftp.debian.org squeeze/contrib Translation-cs                        
Cíl http://security.debian.org squeeze/updates Release.gpg                      
Ign http://security.debian.org squeeze/updates/main Translation-cs              
Ign http://security.debian.org squeeze/updates/contrib Translation-cs          
Ign http://ftp.debian.org squeeze/non-free Translation-cs                      
Cíl http://ftp.debian.org squeeze Release                                      
Ign http://security.debian.org squeeze/updates/non-free Translation-cs          
Cíl http://security.debian.org squeeze/updates Release                          
Cíl http://ftp.debian.org squeeze/main Packages/DiffIndex                      
Ign http://security.debian.org squeeze/updates/main Packages/DiffIndex          
Ign http://download.skype.com stable Release.gpg                                
Ign http://download.skype.com stable/non-free Translation-cs                    
Cíl http://ftp.debian.org squeeze/contrib Packages/DiffIndex                    
Cíl http://ftp.debian.org squeeze/non-free Packages/DiffIndex          
Cíl http://ftp.debian.org squeeze/main Sources/DiffIndex                
Cíl http://ftp.debian.org squeeze/contrib Sources/DiffIndex                    
Cíl http://ftp.debian.org squeeze/non-free Sources/DiffIndex                    
Ign http://security.debian.org squeeze/updates/contrib Packages/DiffIndex      
Ign http://security.debian.org squeeze/updates/non-free Packages/DiffIndex      
Ign http://security.debian.org squeeze/updates/main Sources/DiffIndex          
Ign http://security.debian.org squeeze/updates/contrib Sources/DiffIndex        
Ign http://security.debian.org squeeze/updates/non-free Sources/DiffIndex      
Ign http://download.skype.com stable Release                                    
Cíl http://security.debian.org squeeze/updates/main Packages                    
Cíl http://security.debian.org squeeze/updates/contrib Packages        
Cíl http://security.debian.org squeeze/updates/non-free Packages        
Cíl http://security.debian.org squeeze/updates/main Sources            
Cíl http://security.debian.org squeeze/updates/contrib Sources
Cíl http://security.debian.org squeeze/updates/non-free Sources
Ign http://download.skype.com stable/non-free Packages/DiffIndex
Cíl http://download.skype.com stable/non-free Packages
98% [Čekám na hlavičky]                                              31B/s

A pak se to na několik minut sekne na posledním řádku - čekám na hlavičky

Na jiném PC se stejným sources.list a na stejné internetové přípojce problém nemám. Tudíž problém je v PC. Jen nevím kde co opravit / upravit. Za každou radu předem děkuji.

53
Správa a instalace softwaru / Zamknutí verze balíku
« kdy: 29. 01. 2010, 15:45:34 »
Zdárek, v Sidovi jsem měl problém se sestavením Grubu ze dne 28.1.2010, tak jsem provedl downgrade na sestavení z 15.1.2010 (ze Squeeze) a v Synapticu jsem zamknul verzi balíků grub-pc a grub-common. Nicméně Update manager mi stále poté nutí aktualizaci těchto dvou balíků. Taktéž mi ji nutí i apt-get a aptitude. Jak tedy provést zamknutí verze tak, aby mi nebyla aktualizace nabízena?

54
Tak jsem poprvé za dobu co mám ATI a linux (2 roky) nespokojen. Jde o to, že ATI kašle na linux a to proto že za 3 měsíce nebyl nikdo u nich schopen udělat ovladač podporující xorg 7.5. Marně jsem do dneška čekal na verzi 10.1 v domění, že tam podpora nového xorgu bude a ejhle vono nic. To už se mi zdá jako velké opovržení nad uživateli linuxu. Nemáte někdo nějaké info, kdy by mohl být xorg 7.5 podporován?

55
Návrhy a připomínky / http://www.debian-linux.cz/
« kdy: 23. 01. 2010, 20:55:58 »
Proč jsou stránky http://www.debian-linux.cz/ mrtvé? Poslední příspěvek je z 23.11.2009. Od té doby je spousta novinek okolo Debianu. Toto nepovažuju za dobrou vizitku, která by měla lákat nové uživatele.

56
Všeobecná podpora / Odstranění ikony
« kdy: 18. 12. 2009, 16:44:00 »
Ahoj, na svůj Debian Lenny jsem si nainstaloval ikony Humanity, ale zobrazuje se mi vlevo nahoře ikona Ubunutu. Tu bych rád odstranil, nicméně nevím jak. Poradí prosím někdo?


57
Internet a sítě / Empathy [vyřešeno]
« kdy: 06. 12. 2009, 12:54:49 »
Ahoj, nevíte někdo proč v Empathy (Squeeze) je jen podpora Jabberu, Google talk a jakéhosi protokolu Salut? Empathy přeci podporuje spoustu jiných protokolů, tak proč nejsou ve Squeeze? Hledal jsem na netu, ale nic jsem nenašel.

58
Správa a instalace softwaru / Problém s aktualizací
« kdy: 17. 10. 2009, 08:19:03 »
Ahoj, na desktopu mám Lennyho, ale do Virtualboxu jsem si dal Squeeze. Ale pokud chci Squeeze aktualizovat, tak mi se objeví hláška viz foto. Zároveň nejdou nainstalovat ani přídavky pro hosta, viz druhé foto. Dokázal by mi někdo prosím poradit? Předem děkuji.


59
Všeobecná podpora / Upgrade Lenny to Squeeze
« kdy: 01. 10. 2009, 18:22:51 »
Ahoj, jakožto ne úplně zdatný uživatel Debianu bych si potřeboval jednou pro vždy udělat jasno. Jedná se mi o to, jestli existuje nějaký jediný a správný (oficiální?) postup, jak bezpečně a správně provést upgrade z Lennyho na Squeeze. Hledal jsem na netu, dostal jsem různé rady, a postupy se dost lišily. Jak to tedy doopravdy je?

Mám v současné době totiž velké problémy na Squeeze přejít. Když jsem upgradoval z Lennyho, tak mi vůbec nenaběhli Xka a nepodařilo se mi systém nijak zachránit. Když jsem provedl čistou instalaci, tak jsem zase měl problém s bugem v Nautilu, kdy při pokusu o nastavení celý spadl a také se mi vůbec neinicializoval ovladač na GK ATI.

Ještě přikládám postup, který jsem použil pro upgrade:

V souboru /etc/apt/sources.list jsem editoval položky lenny na squeeze popřípadě stable na testing
Poté postupně zadal do terminalu tyto příkazy:
sudo aptitude update
sudo aptitude install apt dpkg aptitude
sudo aptitude full-upgrade

poté restart a tma.

60
Správa a instalace softwaru / Aktualizace balíků z Backports
« kdy: 11. 09. 2009, 21:58:40 »
Ahoj, mám následující dotaz. Vzhledem k tomu, že pro mě je v současné době testing absolutně nepoužitelný, tak mám ku spokojenosti Lennyho. Chci používat některé balíky z Backport, jako třeba OpenOffice.org, Pidgin, atd. Můj dotaz zní: Pokud aktualizuju některý z programů z verze Lenny na Lenny-backports, bude se poté automaticky aktualizovat, pokud se v Backports objeví jeho novější verze?

Abych uvedl příklad:

Pidgin je v Lennym ve verzi 2.4.3
V backports je nyní verze 2.5.9
Jde mi o to, pokud se v backports objeví například verze 2.6.1, tak jestli se mi sama nabídne k aktualizaci nebo jestli si novější verzi musím hlídat sám. A tudíž aktualizaci provádět ručně.

Stran: 1 2 3 [4] 5