Debian fórum

Dotazy => Server => Téma založeno: ZZromanZZ 04. 04. 2012, 18:48:38

Název: pouze tls 1.2 s apache a openssl
Přispěvatel: ZZromanZZ 04. 04. 2012, 18:48:38
Zdravim, je mozne nastavit Apache a  mod_ssl tak, aby komunikovat pouze pres tls 1.2? V testingu uz je openssl 1.0.1 s podporou tls 1.1 a 1.2, ale mod_ssl me necha nastavit v direktive SSLProtocol jenom TLSv1, a tudiz apache komunikuje na vsech TLS 1.0+ protokolech a se vsemi prislusnymi siframi. Z meho pohledu to vypada ze openssl OK, ale mod_sll usnul na vavrinech a nema funkcnost implementovanou... Diky
Název: Re:pouze tls 1.2 s apache a openssl
Přispěvatel: ulo 05. 04. 2012, 21:48:20
Podle mě máš pravdu a mod_ssl vskutku TLSv1.2 zatím neumí (viz. http://httpd.apache.org/docs/2.2/mod/mod_ssl.html (http://httpd.apache.org/docs/2.2/mod/mod_ssl.html)) a tak jsem jen na rychlo objevil, že to někdo vyřešil přes workaround pomocí GnuTLS a mod_gnutls (http://blog.whitehorses.nl/2011/09/13/tls-v1-2-in-apache-for-the-pkioverheid/ (http://blog.whitehorses.nl/2011/09/13/tls-v1-2-in-apache-for-the-pkioverheid/) a http://modgnutls.sourceforge.net/downloads/docs/mod_gnutls_manual-0.1.html (http://modgnutls.sourceforge.net/downloads/docs/mod_gnutls_manual-0.1.html)).
Název: Re:pouze tls 1.2 s apache a openssl
Přispěvatel: ZZromanZZ 06. 04. 2012, 09:58:30
Diky navedls me dobre... nasel jsem ze v Apachi 2.4 uz to mod_sll bude umet. Viz.: http://httpd.apache.org/docs/2.4/mod/mod_ssl.html (http://httpd.apache.org/docs/2.4/mod/mod_ssl.html). O GnuTLS vim ale tohle reseni nechci.
Název: Re:pouze tls 1.2 s apache a openssl
Přispěvatel: ulo 06. 04. 2012, 12:11:45
Není zač a že se ti do GnuTLS nechce se fakt nedivím, taky zastávám názor si počkat na hotový a čistý řešení.