Tipy, triky, návody - pouze návody, nevkládat dotazy! > Správa, údržba a nastavení systému

Ako na downgrade Unstable --> Testing (Lenny)

<< < (2/3) > >>

Jan Skořepa:
Taky mně se po dist-upgrade nic většího nestahovalo (asi jen 15 balíčků). Ale podle jiného návodu (http://www.leune.org/blog/kees/2005/05/downgrading-debian-gnulinux-fr.html) jsem do preferences vložil toto:

--- Kód: ---X-comment: Force downgrade to testing.
Package: *
Pin: release a=testing
Pin-Priority: 1100

--- Konec kódu ---
A potom to už downgradovalo 177 balíčků, takže zřejmě už se to povedlo.

Yontalcar:
@Erino72
aby správce balíků přistoupil k downgradování, musí mít cílový balík prioritu >1000

Hynek (Pichi) Vychodil:
Tenhle návod mi nefunguje, stále se to snaží instalovat balíky z unstable:


--- Kód: ---# cat /etc/apt/preferences
Package: *
Pin: release a=testing
Pin-Priority: 1100

# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  cmake hpijs-ppds libgtkhtml-editor-common libgtkhtml-editor0 lzop openoffice.org-base-core openoffice.org-core openoffice.org-evolution openoffice.org-report-builder-bin
  openoffice.org-thesaurus-cs openoffice.org-thesaurus-en-us
The following NEW packages will be installed:
  acl gcc-4.5-base git-man libassuan0 libcamel1.2-19 libebook1.2-10 libecal1.2-8 libedata-book1.2-8 libedata-cal1.2-10 libedataserver1.2-14 libedataserverui1.2-11 libfile-which-perl
  libgtkhtml-editor-3.14-0 libgtkhtml-editor-3.14-common liblvm2app2.2 libpackage-stash-xs-perl libraptor2-0 librasqal3 libreoffice libreoffice-base libreoffice-base-core libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge libreoffice-filter-binfilter libreoffice-filter-mobiledev libreoffice-gcj libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-kde libreoffice-math libreoffice-officebean libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-oxygen libreoffice-style-tango libreoffice-writer linux-image-2.6.37-1-amd64
The following packages will be upgraded:
  acpid apache2 apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common binfmt-support binutils binutils-doc bristol bristol-data bsdutils busybox cmake-data desktop-base dhcp3-client
  djvulibre-desktop dmsetup dnsmasq-base eject evince evince-common evolution evolution-common evolution-data-server evolution-data-server-common evolution-exchange evolution-plugins
  evolution-webcal exiftran fio firmware-linux-free foo2zjs foomatic-filters-ppds gir1.0-gtk-2.0 git git-all git-arch git-cvs git-daemon-run git-doc git-email git-gui git-svn gitk gitweb
  gnome-menus gnome-panel gnome-panel-data gnupg gnupg-agent gnupg-curl gnupg2 gpgsm gpgv gstreamer0.10-ffmpeg hpijs hplip hplip-cups hplip-data hplip-doc hplip-gui htop inkscape iputils-ping
  isc-dhcp-client isc-dhcp-common java-wrappers kaffeine kbd keyboard-configuration ledit lib32gcc1 lib32stdc++6 libblkid1 libcap2 libccid libchamplain-0.4-0 libchamplain-gtk-0.4-0 libdc1394-22
  libdevmapper1.02.1 libdjvulibre-text libdjvulibre21 libebackend1.2-0 libegroupwise1.2-13 libevince2 libevolution libfindlib-ocaml libfindlib-ocaml-dev libfreetype6 libfreetype6-dev libgc1c2
  libgcc1 libgdata-common libgdata7 libgfortran3 libglib2.0-0 libglib2.0-bin libglib2.0-dev libgnome-menu2 libgomp1 libgps19 libgtkhtml3.14-19 libhpmud0 libimobiledevice1 libjpeg-progs libjpeg8
  libksba8 liblzo2-2 libmms0 libmpfr4 libnamespace-clean-perl libnspr4-0d libpackage-stash-perl libpam-modules libpam-runtime libpam0g libpanel-applet2-0 libpci3 libpcsclite1 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libpolkit-gtk-1-0 libportaudio2 libpulse-browse0 libpulse-dev libpulse-mainloop-glib0 libpulse0 libraw1394-11 librdf0 librpm1 librpmio1 libsane
  libsane-extras libsane-hpaio libsgutils2-2 libsox-fmt-alsa libsox-fmt-base libsox1b libspectre1 libssl-dev libssl0.9.8 libstdc++6 libtasn1-3 libtest-pod-perl libtotem-plparser17 libunique-1.0-0
  libusbmuxd1 libutempter0 libuuid1 libvorbis-dev libvorbis0a libvorbisenc2 libvorbisfile3 libwebkit-1.0-2 libwebkit-1.0-common libwildmidi1 libwnck-common libwnck22 libxft2 libxml-twig-perl
  libxmlgraphics-commons-java linux-base linux-image-2.6-amd64 linux-libc-dev login lvm2 lynx lynx-cur mobile-broadband-provider-info mount netcat netcat-traditional ocaml-findlib openoffice.org
  openoffice.org-base openoffice.org-calc openoffice.org-common openoffice.org-draw openoffice.org-emailmerge openoffice.org-filter-binfilter openoffice.org-filter-mobiledev openoffice.org-gcj
  openoffice.org-gnome openoffice.org-gtk openoffice.org-help-en-us openoffice.org-impress openoffice.org-java-common openoffice.org-kde openoffice.org-math openoffice.org-officebean
  openoffice.org-style-galaxy openoffice.org-style-oxygen openoffice.org-style-tango openoffice.org-writer openssl os-prober passwd patchutils pax pbuilder pciutils pcscd perltidy pinentry-curses
  pinentry-gtk2 pinentry-qt4 policykit-1 policykit-1-gnome pulseaudio pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils purifyeps
  python-beautifulsoup python-gmenu python-ipy python-mako python-markupsafe python-pysqlite2 python-uno rpm-common rpm2cpio samba-common samba-common-bin sane-utils shared-mime-info smbclient
  sox telepathy-gabble udisks uno-libs3 ure usbmuxd util-linux uuid-runtime x11-xfs-utils x11-xkb-utils x11-xserver-utils
242 upgraded, 43 newly installed, 11 to remove and 0 not upgraded.
Need to get 270 MB/359 MB of archives.
After this operation, 1,362 kB disk space will be freed.
Do you want to continue [Y/n]?
Get:1 http://ftp.cz.debian.org/debian/ unstable/main libreoffice-filter-binfilter amd64 1:3.3.1~rc2-1 [9,158 kB]
Get:2 http://ftp.cz.debian.org/debian/ unstable/main openoffice.org-filter-binfilter all 1:3.3.0-6 [120 kB]                                                                                         
Get:3 http://ftp.cz.debian.org/debian/ unstable/main openoffice.org-draw all 1:3.3.0-6 [120 kB]                                                                                                     
Get:4 http://ftp.cz.debian.org/debian/ unstable/main openoffice.org-calc all 1:3.3.0-6 [120 kB]                                                                                                     
Get:5 http://ftp.cz.debian.org/debian/ unstable/main openoffice.org-base all 1:3.3.0-6 [120 kB]                                                                                                     
Get:6 http://ftp.cz.debian.org/debian/ unstable/main openoffice.org-writer all 1:3.3.0-6 [120 kB]                                                                                                   
Get:7 http://ftp.cz.debian.org/debian/ unstable/main ure amd64 1.7.0+LibO3.3.1~rc2-1 [1,795 kB]                                                                                                     
Get:8 http://ftp.cz.debian.org/debian/ unstable/main uno-libs3 amd64 1.7.0+LibO3.3.1~rc2-1 [1,620 kB]                                                                                               
Get:9 http://ftp.cz.debian.org/debian/ unstable/main libreoffice-common all 1:3.3.1~rc2-1 [20.0 MB]                                                                                                 
8% [9 libreoffice-common 8,694 kB/20.0 MB 43%]                                                                                                                                     775 kB/s 5min 20s
--- Konec kódu ---

Hynek (Pichi) Vychodil:
Hmm, tak jsem zjistil, že jsem neměl v sources testing ale squeeze, jenže ani tak mi to nechce nic downgradovat.

Ota Trkola:
Mám pocit, že downgrade není podporováno. Pokud se to někomu povede ze Sida na Wheezy, tak se může podělit.

Navigace

[0] Seznam témat

[#] Další strana

[*] Předchozí strana

Přejít na plnou verzi