Debian fórum

Dotazy => Hardware => Téma založeno: piquick 17. 09. 2021, 07:45:36

Název: Problém s SD/MMC čtečkou 02 Micro na ntb Lenovo E470
Přispěvatel: piquick 17. 09. 2021, 07:45:36
Zdravím, mám následující problém se čtečkou karet na Lenovo E470 debian testing Xfce:

1. Vložím kartu - normálně se připojí a lze s ní pracovat
2. Dám vysunout kartu (thunar) - objeví se hláška: "Error ejecting /dev/mmcblk0: Command-line 'eject´/dev/mmcblk0 exited with non-zero exit status 1: eject: nelze vysunout."
3. Dám ještě jednou vysunout, objeví se hláška: No object for D-bus interface > ikona na ploše a v Thunaru zůstává
4. Dám připojit, objeví se hláška: No object for D-bus interface

Vypadá to, že se karta fakticky odpojí, ale v systému někde zůstane viset. Prohledával jsem všechna fóra a zkoušel kde co, nejčastěji přes debug_quirks2, ale nic nepomáhá.

Čtečka je (lspci) 02:00.0 SD Host controller: O2 Micro, Inc. SD/MMC Card Reader Controller (rev 01)

Nevěděl by někdo, co s tím? Zajímavý je, že v ubuntu čtečka pracovala normálně. Dík za případnou odpověď.
Název: Re:Problém s SD/MMC čtečkou 02 Micro na ntb Lenovo E470
Přispěvatel: Roman Horník 02. 10. 2021, 14:50:46
Pravděpodobně chyba komunikace Thunaru s DBusem, nebo chyba DBusu. Zkus je vzít ze Sida, jestli je to nutný, ale evidentně to i přes kecy funguje (volá příkazy eject a (u)mount).
EDIT: Teď mám potvrzeno, že na Sidovi to funguje zcela normálně.
Název: Re:Problém s SD/MMC čtečkou 02 Micro na ntb Lenovo E470
Přispěvatel: piquick 05. 10. 2021, 07:48:35
Díky za odpověď, zkusil jsem - dbus i thunar už mezi tím propadly do testingu a stejně to hází ty podivné hlášky. Když se však podívám do syslogu, tam kernel, systemd i udisksd svorně tvrdí, že SD karta se úspěšně připojila i úspěšně odpojila. Asi to bude nějaká hloupost. Zkusil jsem to ze zoufalství i na ubuntu a tam se to chová normálně.