Autor Téma: Jak se zbavit exim4?  (Přečteno 2555 krát)

Offline Firzen

  • Začátečník
  • **
  • Příspěvků: 58
    • Zobrazit profil
    • Be root
Jak se zbavit exim4?
« kdy: 05. 09. 2011, 14:42:55 »
Dobrý den,

tak jsem si řekl, že v systému skutečně nepotřebuji mail sever. Chtěl jsem odinstalovat exim4, jenže ejhle.. google-earth-stable ho má v závoslostech. Neví někdo, na co - proboha - google earth potřebuje mailový server? A je to vůbec normální??

Předem dík.
AMD Phenom II X6 1100T@3,3GHz, Gigabyte GeForce GT 430 1GiB, 8GiB RAM, 1TiB SATA3 HDD, Nokia N900
OS: Debian 6.0 Squeeze, Maemo 5
Nyní můžete počítač bezpečně vypnout.

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.302
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Re:Jak se zbavit exim4?
« Odpověď #1 kdy: 05. 09. 2011, 16:58:12 »
Závislosti Google Earth 6 jsou vůbec podivné, také jsem se tomu divil, ale nikde jsem nedohledal proč se závislosti tak radikálně změnily oproti verzi 5.

Offline Hobild

  • Uživatel
  • ***
  • Příspěvků: 233
    • Zobrazit profil
  • Jabber: hobil@jabber.root.cz
Re:Jak se zbavit exim4?
« Odpověď #2 kdy: 07. 09. 2011, 17:28:27 »
Domnivam se, ze exim4 neni v zavislostech GE 6. Mam na disku "deb" instalacky verzi 6.0.2 a 6.0.3:
6.0.2:
Kód: [Vybrat]
  dpkg -I googleearth_6.0.2.2074+0.6.0-1_i386.deb
 nový formát balíku, verze 2.0.
.....
 Version: 6.0.2.2074+0.6.0-1
.....
 Depends: ttf-dejavu | ttf-bitstream-vera | msttcorefonts, lsb-core, libqtcore4, libgl1-mesa-glx, libc6 (>= 2.0), libc6 (>= 2.1.3), libc6 (>= 2.2), libc6 (>= 2.3), libc6 (>= 2.3.2), libc6 (>= 2.3.6-6~), libc6 (>= 2.4), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libice6 (>= 1:1.0.0), libsm6, libstdc++6 (>= 4.1.1), libxext6, libxrender1, libx11-6, zlib1g (>= 1:1.1.4)
....
a ten novejsi je na tom obdobne:
Kód: [Vybrat]
   # dpkg -I googleearth_6.0.3.2197+0.6.0-1_i386.deb
.....
 Version: 6.0.3.2197+0.6.0-1
....
Depends: ttf-dejavu | ttf-bitstream-vera | msttcorefonts, lsb-core, libqtcore4, libgl1-mesa-glx, libc6 (>= 2.0), libc6 (>= 2.1.3), libc6 (>= 2.2), libc6 (>= 2.3), libc6 (>= 2.3.2), libc6 (>= 2.3.6-6~), libc6 (>= 2.4), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libice6 (>= 1:1.0.0), libsm6, libstdc++6 (>= 4.1.1), libxext6, libxrender1, libx11-6, zlib1g (>= 1:1.1.4)
....
exim4 tam nikde nevidim, polozku pro navrhovane balicky (Suggests) maji oba baliky prazdne. Zkus exim odinstalovat bez kontroly zavislosti, GE by ti mel chodit i bez nej.
H.

Offline Firzen

  • Začátečník
  • **
  • Příspěvků: 58
    • Zobrazit profil
    • Be root
Re:Jak se zbavit exim4?
« Odpověď #3 kdy: 09. 09. 2011, 13:13:24 »
Ono totiž exim4 vyžaduje ten balíček lsb-core .. a ten zase vyžaduje google earth no.  :-\
AMD Phenom II X6 1100T@3,3GHz, Gigabyte GeForce GT 430 1GiB, 8GiB RAM, 1TiB SATA3 HDD, Nokia N900
OS: Debian 6.0 Squeeze, Maemo 5
Nyní můžete počítač bezpečně vypnout.

Offline Hobild

  • Uživatel
  • ***
  • Příspěvků: 233
    • Zobrazit profil
  • Jabber: hobil@jabber.root.cz
Re:Jak se zbavit exim4?
« Odpověď #4 kdy: 09. 09. 2011, 20:33:45 »
Jak rikam - zkus exim odinstalovat bez kontroly a odebrani zavislosti. V zavislostech lsb-core jsou alternativy pro vyuzivani jinych MTA nez je exim, takze by problem nastat nemel.
Kód: [Vybrat]
  aptitude show lsb-core
Balík: lsb-core                       
...
Verze: 3.2-23.2squeeze1
...
Závisí na: ... exim4 | mail-transport-agent, at, ...

H.