Autor Téma: Debian Upgrade  (Přečteno 10168 krát)

Offline eXt_r33m

  • Začátečník
  • **
  • Příspěvků: 69
  • skill :: aggressive-newbie
    • Zobrazit profil
Debian Upgrade
« kdy: 07. 05. 2009, 17:13:29 »
Zdravim,
potrebuji podporu ext4 na Debian Lenny... je mozne ze si do zdroju pridam testing zdroj a stahnu jadro podporujici ext4? Nebo je lepsi stahnout testing a cista instalace?

Diki moc...
AMD Opteron Processor 144 1.8 Ghz;2x512 MiB DDR1;ATI Radeon HD 2600 Pro 256 MiB DDR3;Atheros 802.11 WiFi;Boot: WinXP + Ubuntu 9.04 amd64 + Arch linux amd64

Offline Boogey

  • Uživatel
  • ***
  • Příspěvků: 159
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #1 kdy: 07. 05. 2009, 18:54:04 »
Urcite staci stahnout si jen jadro a nainstalovat. Pridanim testingu do zdroju ale zpusobis update celeho systemu na testing. Musis nastavit vetvi testing jinou prioritu(pin). Pak instalujes: sudo aptitude -t testing install BALIK. Mam ale dojem, ze vetev testing neobsahuje jadro s podporou ext3. Musis asi unstable nebo vanillu.

http://wiki.debian.org/AptPinning
http://packages.debian.org/search?suite=sid&section=all&arch=any&searchon=names&keywords=linux-image-2.6.29
http://kernel.org/

Debian Squeeze 32bit, Kernel 2.6.26-2, (Server)
AMD Duron 700MHz@1Ghz, 640MB ram, GeForce 4 MX 64MB
Apache2, PHP5, Samba, ProFTPd, MySQL, KDE 4.2.2(na testovani)

Offline Erich Stark

  • Aktivní­ uživatel
  • ****
  • Příspěvků: 546
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #2 kdy: 09. 05. 2009, 17:34:23 »
Ak sa nemylim tak i686 je pre 32 bitove procesory takze by ti malo stacit ak stiahnes a nainstalujes tento balik
Kód: [Vybrat]
http://packages.debian.org/sid/linux-image-2.6.29-2-686
" The box said that I needed to have Windows XP or better ... so I installed Debian ."

Offline eXt_r33m

  • Začátečník
  • **
  • Příspěvků: 69
  • skill :: aggressive-newbie
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #3 kdy: 10. 05. 2009, 18:31:37 »
Diks uz bezim na novym jadre... Snazil jsem se neco udelat s tym Pin-Priority ale nevim jestli byl vysledek jaky jsem chtel..  ??? nevadi kazdopadne jsem musel znova rozdelat wifi i grafiku takze sranda byla  :)
PS: i tak mi to moc nepomohlo protoze jsem chtel improtovat do Virtualboxu virtualni disk na ext4 -> potreboval jsem podporu ext4, to se mi povedlo jenze ted mi zase nejede virtualbox  ;D
AMD Opteron Processor 144 1.8 Ghz;2x512 MiB DDR1;ATI Radeon HD 2600 Pro 256 MiB DDR3;Atheros 802.11 WiFi;Boot: WinXP + Ubuntu 9.04 amd64 + Arch linux amd64

Offline Erbureth

  • Začátečník
  • **
  • Příspěvků: 33
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #4 kdy: 10. 05. 2009, 18:37:42 »
jenze ted mi zase nejede virtualbox  ;D

Pokud máš nové jádro, tak musíš rekompilovat modul pro VB, manuál ti poradí, jak na to.
Debian Squeeze AMD64, 2.6.27, KDE 4.2.2 @ HP Compaq 6830s
Debian Squeeze, 2.6.26, KDE 4.2.2 @ AthlonXP 2000+, 512 MB, Radeon 9000 128 MB

Whatever happened, happened, and could not had happened any other way.

Offline eXt_r33m

  • Začátečník
  • **
  • Příspěvků: 69
  • skill :: aggressive-newbie
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #5 kdy: 10. 05. 2009, 18:41:52 »
Jj ja vim jen na to potrebuji balik virtualbox-ose-modules, jenze ten potrebuje linux-modules-2.6.29-1-amd64 a takovy balicek jeste neexistuje :(
AMD Opteron Processor 144 1.8 Ghz;2x512 MiB DDR1;ATI Radeon HD 2600 Pro 256 MiB DDR3;Atheros 802.11 WiFi;Boot: WinXP + Ubuntu 9.04 amd64 + Arch linux amd64

Offline Erbureth

  • Začátečník
  • **
  • Příspěvků: 33
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #6 kdy: 10. 05. 2009, 19:54:23 »
použij virtualbox-ose-source a zkompiluj přes module-assistant
Kód: [Vybrat]
# m-a prepare
# m-a get virtualbox-ose
# m-a build virtualbox-ose
# m-a install virtualbox-ose
Debian Squeeze AMD64, 2.6.27, KDE 4.2.2 @ HP Compaq 6830s
Debian Squeeze, 2.6.26, KDE 4.2.2 @ AthlonXP 2000+, 512 MB, Radeon 9000 128 MB

Whatever happened, happened, and could not had happened any other way.

Offline eXt_r33m

  • Začátečník
  • **
  • Příspěvků: 69
  • skill :: aggressive-newbie
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #7 kdy: 10. 05. 2009, 20:17:55 »
Pri m-a build virtualbox-ose mi to vyhodi Error 2... Je mozne ze nemam nejake potrebne kompilatori nebo?

Diky
AMD Opteron Processor 144 1.8 Ghz;2x512 MiB DDR1;ATI Radeon HD 2600 Pro 256 MiB DDR3;Atheros 802.11 WiFi;Boot: WinXP + Ubuntu 9.04 amd64 + Arch linux amd64

Offline Erbureth

  • Začátečník
  • **
  • Příspěvků: 33
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #8 kdy: 10. 05. 2009, 20:31:15 »
Kód: [Vybrat]
# m-a prepareby se měl postarat o kompilátory a hlavičkové soubory, ale je možné, že modul potřebuje něco dalšího. Podrobnější popis chyby nemáš?
Debian Squeeze AMD64, 2.6.27, KDE 4.2.2 @ HP Compaq 6830s
Debian Squeeze, 2.6.26, KDE 4.2.2 @ AthlonXP 2000+, 512 MB, Radeon 9000 128 MB

Whatever happened, happened, and could not had happened any other way.

Offline eXt_r33m

  • Začátečník
  • **
  • Příspěvků: 69
  • skill :: aggressive-newbie
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #9 kdy: 10. 05. 2009, 21:46:18 »
Celej vystup buildu:
Kód: [Vybrat]
Extracting the package tarball, /usr/src/virtualbox-ose.tar.bz2, please wait...
kmk  -f debian/rules clean
kmk: Nothing to be done for `clean'.
kmk  -f debian/rules kdist_clean kdist_config binary-modules
kmk  -f debian/rules clean
kmk[1]: Entering directory `/usr/src/modules/virtualbox-ose'
kmk[1]: Nothing to be done for `clean'.
kmk[1]: Leaving directory `/usr/src/modules/virtualbox-ose'
kmk: Nothing to be done for `kdist_config'.
for templ in ; do \
    cp $templ `echo $templ | sed -e 's/_KVERS_/2.6.29-2-amd64/g'` ; \
  done
for templ in `ls debian/*.modules.in` ; do \
    test -e ${templ%.modules.in}.backup || cp ${templ%.modules.in} ${templ%.modules.in}.backup 2>/dev/null || true; \
    sed -e 's/##KVERS##/2.6.29-2-amd64/g ;s/#KVERS#/2.6.29-2-amd64/g ; s/_KVERS_/2.6.29-2-amd64/g ; s/##KDREV##/2.6.29-4/g ; s/#KDREV#/2.6.29-4/g ; s/_KDREV_/2.6.29-4/g  ' < $templ > ${templ%.modules.in}; \
  done
dh_testroot
dh_clean -k
# Build the module
kmk -C /lib/modules/2.6.29-2-amd64/build M=/usr/src/modules/virtualbox-ose
kmk[1]: Entering directory `/usr/src/linux-headers-2.6.29-2-amd64'
kmk[2]: Entering directory `/usr/src/linux-headers-2.6.29-2-common'
kmk[3]: Entering directory `/usr/src/linux-headers-2.6.29-2-amd64'
kmk[4]: Entering directory `/usr/src/linux-headers-2.6.29-2-amd64'
/usr/src/modules/virtualbox-ose/linux/SUPDrv-linux.c: In function ‘VBoxDrvLinuxCreate’:
/usr/src/modules/virtualbox-ose/linux/SUPDrv-linux.c:734: error: ‘struct task_struct’ has no member named ‘euid’
/usr/src/modules/virtualbox-ose/linux/SUPDrv-linux.c:735: error: ‘struct task_struct’ has no member named ‘egid’
kmk[4]: *** [/usr/src/modules/virtualbox-ose/linux/SUPDrv-linux.o] Error 1
kmk[4]: Leaving directory `/usr/src/linux-headers-2.6.29-2-amd64'
kmk[3]: *** [_module_/usr/src/modules/virtualbox-ose] Error 2
kmk[3]: Leaving directory `/usr/src/linux-headers-2.6.29-2-amd64'
kmk[2]: *** [sub-make] Error 2
kmk[2]: Leaving directory `/usr/src/linux-headers-2.6.29-2-common'
kmk[1]: *** [all] Error 2
The failing command:
@$(MAKE) $(MAKEARGS) $(cmd)
kmk[1]: Leaving directory `/usr/src/linux-headers-2.6.29-2-amd64'
kmk: *** [binary-modules] Error 2
make: *** [kdist_build] Error 2
BUILD FAILED!
See /var/cache/modass/virtualbox-ose-source.buildlog.2.6.29-2-amd64.1241984663 for details.
Build failed. Press Return to continue...
AMD Opteron Processor 144 1.8 Ghz;2x512 MiB DDR1;ATI Radeon HD 2600 Pro 256 MiB DDR3;Atheros 802.11 WiFi;Boot: WinXP + Ubuntu 9.04 amd64 + Arch linux amd64

Offline Erbureth

  • Začátečník
  • **
  • Příspěvků: 33
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #10 kdy: 10. 05. 2009, 22:39:51 »
hm, imho to možná bude nějaká chyba v hlavičkách kernelu (pokud se domnívám správně, že složka virtualbox-ose/linux jsou přilinkované hlavičky), máš nainstalovanou aktuální verzi linux-headers-2.6.29 ze Sidu? Pokud jo, tak to zkus nahlásit jako bug.
Debian Squeeze AMD64, 2.6.27, KDE 4.2.2 @ HP Compaq 6830s
Debian Squeeze, 2.6.26, KDE 4.2.2 @ AthlonXP 2000+, 512 MB, Radeon 9000 128 MB

Whatever happened, happened, and could not had happened any other way.

Offline eXt_r33m

  • Začátečník
  • **
  • Příspěvků: 69
  • skill :: aggressive-newbie
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #11 kdy: 11. 05. 2009, 16:04:11 »
Headers njnovsi mam... nevim kdyz nemuzu naistalovat balik kvuli dependencies, pochybuji ze to budu moct skompilovat  ??? nevadi...  skousim to nahlasit jako bug nebo pockam az dodelaji balicek linux-modules
AMD Opteron Processor 144 1.8 Ghz;2x512 MiB DDR1;ATI Radeon HD 2600 Pro 256 MiB DDR3;Atheros 802.11 WiFi;Boot: WinXP + Ubuntu 9.04 amd64 + Arch linux amd64

Offline Boogey

  • Uživatel
  • ***
  • Příspěvků: 159
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #12 kdy: 11. 05. 2009, 16:11:27 »
Co zkusit nejnovejsi virtualbox-ose-source s nejnovejsi vanilkou? To by mohlo fungovat.

Pripadne zkus ze SIDa ten modul:
http://packages.debian.org/sid/virtualbox-ose-source

Nebo celej virtualbox.
« Poslední změna: 11. 05. 2009, 16:14:58 od Boogey »
Debian Squeeze 32bit, Kernel 2.6.26-2, (Server)
AMD Duron 700MHz@1Ghz, 640MB ram, GeForce 4 MX 64MB
Apache2, PHP5, Samba, ProFTPd, MySQL, KDE 4.2.2(na testovani)

Offline eXt_r33m

  • Začátečník
  • **
  • Příspěvků: 69
  • skill :: aggressive-newbie
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #13 kdy: 11. 05. 2009, 21:45:10 »
Hurray diki moc... asi jsem pako a mel jsem virtualbox z stable ale source ze sida nebo tak nejak... kazdopadne naistaloval jsem nejnovsi verzi virtualboxu, source, skompiloval jsem pomoci m-a a pak uz jen modprobe vboxdrv..... :)  ;D
AMD Opteron Processor 144 1.8 Ghz;2x512 MiB DDR1;ATI Radeon HD 2600 Pro 256 MiB DDR3;Atheros 802.11 WiFi;Boot: WinXP + Ubuntu 9.04 amd64 + Arch linux amd64

Offline eXt_r33m

  • Začátečník
  • **
  • Příspěvků: 69
  • skill :: aggressive-newbie
    • Zobrazit profil
Re: Debian Upgrade
« Odpověď #14 kdy: 12. 05. 2009, 14:45:58 »
Aaaah serial pokracuje :D
1.) Zase jsem musel dat modprobe vboxdrv... to az tak ale nevadi...
2.) Pod virtualboxe nejde emulovat 64 bitovy system?!

dik
AMD Opteron Processor 144 1.8 Ghz;2x512 MiB DDR1;ATI Radeon HD 2600 Pro 256 MiB DDR3;Atheros 802.11 WiFi;Boot: WinXP + Ubuntu 9.04 amd64 + Arch linux amd64