Autor Téma: Upgrade z Lenny na Squeeze - konflikt udev a kernelu - rozbití systému  (Přečteno 7495 krát)

Offline Martin 'Želva' Malý

  • Začátečník
  • **
  • Příspěvků: 57
  • Zalezlej v krunýři
    • Zobrazit profil
    • Želvův zápisník
Dobrý večer,

nainstaloval jsem si Debian Lenny 5.03. Některé programy mi ale přišli zastaralé, a tak jsem se rozhodl, že to stehjně upgraduju na Squeeze. Udělal jsem toto:

aptitude update && aptitude upgrade
předělání sources.listu z lenny na squeeze
aptitude update
aptitude dist-upgrade

No, všechno jelo v pohodě, stáhl jsem přes giga balíčků, až... Chtěl se aktualizovat udev. Začal házet chyby. xserver na mě začal řvát, že se nanakonfiguruje. Upgrade se zastavil - hodil mě zpátky do shellu. Zkusil jsem dát znovu dist-upgarde, pár balíčků se zase aktualizovalo, ale za chvilku zase začal řvát udev a konec.

Problém je asi ten, že ten udev na mě řve, že se chce aktualizovat pod novým kernelem. Já mám 2.6.26. Už se dokonce nainstaloval (po tom, když jsem panicky furt dával dist-upgrade za sebou) 2.6.30-2, ale neudělal se initrd, takže nevím jak do něj nabootovat. Když mu napíšu, že chci nainstalovat kernel (aptitude install linux-image-2.6.30-2-486), tak to řeší závislosti a nakonec prohlásí, že aktualizuje udev, což se mu nepovede...

Je to začarované kolečku. Kernel se nechce nainstalovat a místo toho chce aktualizovat udev a udev se chce aktualizovat pod novým kernelem.

Uff...

Při upgardu, kdy jsem panicky dist-upgarde asi desetkrát opakoval, se mi už odinstalovalo gnome, gdm, network manager... Systém se mi rozkládá...

Dá se s tím prosím něco dělat? Je nejjednodušší si stáhnout weekly-build a nainstalovat testing z něho?

Díky moc.

Zoufalý želvák.  ??? :o :( :'(
... osobní počítače jsou nanic a opravdu nikdy nedělají to, co se po nich chce. Fakt. I když na něm třeba běží Debian, Ubuntu, Widle, Mac, je to skoro furt to samé... :-( ...

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.261
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Odpověděl jsi si sám. Stáhni squeeze a nainstaluj jej. O upgrade z Lennyho na Squeeze jsem se v minulosti párkrát taky pokoušel a nikdy se mi to nepovedlo. Toť moje zkušenost..
Debian Gnome 64bit

Návod na Netinst instalaci

Offline Erich Stark

  • Aktivní­ uživatel
  • ****
  • Příspěvků: 546
    • Zobrazit profil
s takymto upgradom skusenosti nemam,ale raz som skusal z lenny na sid a ten sa nepodaril, resp aj podaril ale zmyzlo mi graf rozhranie, a inak ked chces squeeze tak urcite radsej stiahni weekli-build a nainstaluj nacerstvo hned s ext4 :)
" The box said that I needed to have Windows XP or better ... so I installed Debian ."

Offline Roman Horník

  • Hlavní moderátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.326
    • Zobrazit profil
  • Jabber: roman.hornik@jabber.cz
Mně se upgrade párkrát povedl (jiná možnost v tu dobu nebyla, instalační obrazy netinstall a businesscard Squeezeho a Sida byly zabugovaný), tentokrát ale ne (stejnej problém jako u Martina), instalace proběhla naprosto v pořádku (businesscard, expertní instalace).
Debian Sid 64bit + Mate Desktop Environment
* CPU: Intel Pentium G2020
* GPU: NVIDIA GTX650 1GD5
* MB: LenINovo IH61M
* RAM: 8GiB Deutsche Demokratische Republik 3

Offline Martin 'Želva' Malý

  • Začátečník
  • **
  • Příspěvků: 57
  • Zalezlej v krunýři
    • Zobrazit profil
    • Želvův zápisník
No to je divný... Vždyť je to bug v aptitude! Asi ho nahlásím, až budu tedy mít nainstalovaný systém...

Jak se taková věc může stát Debianu stable... Vždyť už je to jak Ubuntu...
... osobní počítače jsou nanic a opravdu nikdy nedělají to, co se po nich chce. Fakt. I když na něm třeba běží Debian, Ubuntu, Widle, Mac, je to skoro furt to samé... :-( ...

Offline nazir

  • Uživatel
  • ***
  • Příspěvků: 141
  • S.N.A.F.U.
    • Zobrazit profil
  • Jabber: nazir@jabber.cz
Jenže ona se "ta věc" nestala stable branchi, ale mixu stable/testing...
Zkoušel jsi to pomocí apt-get?  Aptitude nepoužívám a s podobným deadlockem jsem se u apt-get nesetkal (to ale může být samozřejmě ovlivněno tehdejším a momentálním stavem balíčků)...

Offline Martin 'Želva' Malý

  • Začátečník
  • **
  • Příspěvků: 57
  • Zalezlej v krunýři
    • Zobrazit profil
    • Želvův zápisník
Ta věc by se neměla stát z mixu stable/tsting, protože ten systém byl asi dni starý a kromě virtualboxu a ovladačů na tiskárnu bylo všechno ze stable větve.


Mimochodem: Už jsem nainstaloval weekly-build testingu Squeeze, teď si chci nainstalovat ovladače a když dám instalovat "nvidia-glx", tak to chce odstranit xorg a s ním asi všechny xorg-* ... Já se z těch debiaňáckejch debilních závislostí zblázním... Když jsem se kouknul do vlastností toho balíku v Synapticu, tak jsem v závislostech nikde nenašel, že se nesnáší s xorgem, ale  v nabídce závislosti → poskytované balíky je napsáno xserver-xorg-video-2 ...

Mám to tedy chápat, že to odstraní starý xorg a dá to tam nějaký xorg 2? ???

Díky moc. Už mám aptu plný zuby...
... osobní počítače jsou nanic a opravdu nikdy nedělají to, co se po nich chce. Fakt. I když na něm třeba běží Debian, Ubuntu, Widle, Mac, je to skoro furt to samé... :-( ...

Offline nazir

  • Uživatel
  • ***
  • Příspěvků: 141
  • S.N.A.F.U.
    • Zobrazit profil
  • Jabber: nazir@jabber.cz
Myslel jsem to tak, že když mixuješ stable a testing (přecházíš ze stable na tasting) , tak to nemusí být nutně vina stable, ale testingu.  Bezproblémový dist-upgrade bych čekal spíš v době střídání stráží, do které je ještě nějaký čas (squeeze ještě nebyl ani zmražený).

Ohledně roztomilé situace s nvidia-glx:
Kód: [Vybrat]
root@nomad:~#  apt-cache policy nvidia-glx
nvidia-glx:
  Installed: (none)
  Candidate: 173.14.09-5
  Version table:
     190.42-3 0
        200 http://ftp.cz.debian.org sid/non-free Packages
     173.14.09-5 0
        990 http://ftp.cz.debian.org squeeze/non-free Packages
root@nomad:~#  apt-get install nvidia-glx -s
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  nvidia-glx: Depends: nvidia-kernel-173.14.09
E: Broken packages
root@nomad:~#  apt-cache policy nvidia-kernel-173.14.09
nvidia-kernel-173.14.09:
  Installed: (none)
  Candidate: (none)
  Version table:

Nvidii nemám, čili chemii okolo jejich ovladačů nesleduju, ale z tohoto mi vyplývá, že prostě momentálně v testingu není binární modul nvidia-kernel-173.14.09, na kterém je nvidia-glx závislý.  Není jej náhodou potřeba nejdřív buildnout pomocí module-assistant (v poolu k této verzi vidím jen source balíčky z roku 2008).

Offline Martin 'Želva' Malý

  • Začátečník
  • **
  • Příspěvků: 57
  • Zalezlej v krunýři
    • Zobrazit profil
    • Želvův zápisník
Aha, měl jsem za to, že Debian není takovej bordel jako Ubuntu... Ale i Debian má své chyby, jak jsem zjistil.

Ovladače jsem tedy doinstaloval z nvidia.com ...
... osobní počítače jsou nanic a opravdu nikdy nedělají to, co se po nich chce. Fakt. I když na něm třeba běží Debian, Ubuntu, Widle, Mac, je to skoro furt to samé... :-( ...

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.261
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Já měl s nvidií na jednom pc taky problémy při upgrade z lennyho na squeeze, tak jsem tam dal rovnou sid a mám pokoj.
Debian Gnome 64bit

Návod na Netinst instalaci

Offline Yontalcar

  • Uživatel
  • ***
  • Příspěvků: 131
  • Semper fidelis
    • Zobrazit profil
  • Jabber: yontalcar@jabber.cz
Aha, měl jsem za to, že Debian není takovej bordel jako Ubuntu... Ale i Debian má své chyby, jak jsem zjistil.

Ovladače jsem tedy doinstaloval z nvidia.com ...
Je Squeeze stable? Není. Ještě není ani zmražený.
Tak si nestěžuj.
NB: ASUS X53U; Debian GNU/Linux Sid amd64 (KDE4)

Jen dvě věci jsou nekonečné - vesmír a lidská hloupost. Tím prvním si ovšem nejsem tak jist. - Albert Einstein

Offline nazir

  • Uživatel
  • ***
  • Příspěvků: 141
  • S.N.A.F.U.
    • Zobrazit profil
  • Jabber: nazir@jabber.cz
Jaký si to uděláš, takový to máš...

BTW: můžete mi vysvětlit ty vaše věčné kecy a narážky proti ubuntu?  Myslíte si, že když od něj utečete (AFAIK je tu většina z vás přeběhlá z fóra na ubuntu.cz (na kterém jsem taky nějakou dobu lurkoval)), tak se z vás přez noc stanou nějací "neo morpheus h4XO®$, co se automaticky musí navážet do těch bloody fuckn's bubuntu noobs, bo tak to příroda a bůh chtěli"?  Fakt si to neumíte odpustit? 
Tuhle exubuntu úchylku pozoruju napříč různými fóry a je mi z ní na blití (a to nejsem bývalý, ani současný uživatel ničeho od canonical, nepočítám-li pár pokusných bootů z live cd).

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.261
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
nazir: já jsem měl Ubuntu 2 roky a když mi přestalo vyhovovat, tak jsem přešel na Debian. Nicméně rodičům jsem ho nainstaloval a věřím, že pro ně je to nejlepší OS, tak nevím kde jsi přišel na ty tvoje hemzy.. nebuď zbytečně chytrej... Na Ubuntu jsem nikdy nenadával, ba naopak spoustě lidem ho doporučuju.
« Poslední změna: 23. 01. 2010, 18:52:54 od otas.pe »
Debian Gnome 64bit

Návod na Netinst instalaci

Offline Ota Trkola

  • Administrátor
  • Aktivní­ uživatel
  • *****
  • Příspěvků: 1.261
    • Zobrazit profil
  • Jabber: otas.pe@jabbim.cz
Nehledě na to, že na ubuntu foru aktivně funguju. Ubuntu je pro mě sympatické distro, i když ho na svým vlastním desktopu nemám.
Debian Gnome 64bit

Návod na Netinst instalaci

Offline nazir

  • Uživatel
  • ***
  • Příspěvků: 141
  • S.N.A.F.U.
    • Zobrazit profil
  • Jabber: nazir@jabber.cz
Debian není takovej bordel jako Ubuntu
Vždyť už je to jak Ubuntu
To samé jako Ubuntu, ale 3x rychlejší  (obzvláště vtipné a zřejmě nevědomky dvojsmyslné v kombinaci s) Ubuntu is an ancient african word meaning "I can't configure Debian"
...atd atd.  Fakt mi tyhle kecy vadí.

Tobě byla určena pouze první věta, ne následující, vizuálně oddělený odstavec...
« Poslední změna: 23. 01. 2010, 18:56:55 od nazir »